Results 1 to 4 of 4

Thread: FX0 call not closing

  1. #1

    Default FX0 call not closing

    Hi There,

    I have two problems, i have an 2xi pbx running firmware 4.1.50 and the fx0 gateway running its latest firmware, i am not using the isdn side of the 2xi but am using three fxo ports for incoming and outgoing lines.

    Problem1:

    when an incoming call comes into reception phone, all works fine, that call is then transferred to another extension, if that call is ended by the outside caller before the extension is picked up, the extension keeps ringing and ringing and if you pick the call up it is dead....

    Problem 2: (might be related)

    An incoming call come into reception, if the call is ened by the outside caller before reception picks up it still rings for about 3 rings before the call is closed...

    regards,

    shaun

  2. #2
    Administrator
    Join Date
    Jun 2006
    Location
    United States
    Posts
    55

    Default

    Shaun,
    It sounds like the Quadro's FXO ports are not configured to match the disconnect signal from the PSTN.
    What happens if you make a call on the FXO to an extension and then disconnect the call from the PSTN side first? Does the call disconnect right away? The FXO disconnect options can be changed in the hidden menu: 172.30.0.1/fxocfg.cgi
    Regards,
    Andy

  3. #3

    Default

    Shaun, both problems described by you are related. It will be useful to check your Disconnect Settings, also there can be another reason for your problem. Let me explain both cases.

    1. There are 3 disconnect parameters on Quadro, that can be found on "fxocfg.cgi" page, mentioned by Andy:

    a. Busy Detection
    b. Disconnect Detection
    c. Silence Detection

    Actually when you are configuring your locale (location) on "Regional Settings and Preferences" page from System Config Wizard, Quadro is putting some predefined options that are courty's national PSTN provider's defaults. If you use another PSTn provider, if your country provider has changed that settings, then you need to adjust the Disconnect Parameters on your Quadro manually. You can ask your provider about disconnect settings, or you can make a capture to find out the correct settings. Just open a TSS ticket in our Support portal and our guys will give you step-by-step directions.

    2. Second thought on this issue. In general, when Disconnect Settings on Quadro aren't configured correctly, the call isn't getting disconnected at all. In your case the call is getting disconnected after 3 rings on the phone. Actually, there is a timeout during which Quadro is confirming that the call is really closed. Your phone will continue to ring during that timeout. You can just decrease it from the same hidden page (fxocfg.cgi), by changing the value of "Fxo Ring Stop Timeout:" for example from 7000 to 5000. Then after call closing your phone will ring shorter, than now. This value must be longer than the interval between rings sent by your telco, not less. Again, you can ask this information from your telco or get it from capture on Quadro's FXO port.
    Please try this second suggestion first and then open a TSS ticket, if this will not work. Inform us about results.
    Last edited by aramk; 01-22-2008 at 03:08 AM.

  4. #4

    Default

    Hi There,

    Thanks for all the help Andy and Aram, i have only installed the ISDN version of the epygi units so far and this is my first fxo GW install connecting to a PSTN, i will be getting into contact with our Telco in South Africa to find their setting and let you guys know how it goes

    regards,

    shaun

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •