Hello

I can see this post is quite old but maybe still relevant to my issue (understanding) of managing display name / callerid.

I have two ip extensions registered on my quadro. When I call between them I see the dsiplay name being sent to the called party , as configured on the quadro, for the calling party extension.

So for example
On the quadro i have ext 306 configured with a dsiplay name of Ext 306 Test Ext

If I place a call to Ext 305 from Ext 306 - The called party (Ext 305) shows a call from Ext 306 Test Ext and the extension number 306

I would like to receive on the called party phone (Ext 306) the originating display name or contact name and not the display name configured on the quadro.

On the IP handset ( I have tested with a Unidata wireless ip handset and Bria client) I set the display name - In the example below I used Ext 306 22 as the display name set on the ip handset.
I don't see this arrive at the called party extension but instead Ext 306 Test Ext as defined as the display name on the quadro.

What am I missing ?

I have included a snapshot of the invite that is sent from Ext 306 when placing a call to Ext 305.


INVITE sip:305@192.168.240.240 SIP/2.0
Via: SIP/2.0/UDP 192.168.240.226:5060;branch=z9hG4bK39635796
From: "Ext 306 22" <sip:locext306@192.168.240.240>;tag=372848532
To: <sip:305@192.168.240.240>
Supported: replaces, 100rel, timer
Call-ID: 1559656965@192.168.240.226
CSeq: 21 INVITE
Session-Expires: 600;refresher=uac
Contact: <sip:locext306@192.168.240.226>
Authorization: Digest username="locext306", realm="quadro", nonce="8cc00019884b1547b85d35cfceabef5a", uri="sip:305@192.168.240.240", response="97d0fcd674f4c490619d7657f26ec4d9", algorithm=MD5, opaque="1517049335"
Content-Type: application/sdp
Max-Forwards: 70
Allow: INVITE,SUBSCRIBE,MESSGE,OPTIONS,REFER,NOTIFY,ACK,B YE,CANCEL
Expires: 180
Content-Length: 417

I have tried to nmodify the settings in hidden page generalconfig.cgi relating to Template for callerid - pbx call but I whateve I set here makes no difference.

I am testing this problem on a Quadro 2x running Firmware Version: 5.3.28

Thank you for any advice.