I am having problems with incoming calls from an ITSP on one of two Quadro2X's

At the ITSP end there are a couple of Direct Indial numbera forwarded to the client ITSP SIP account. I can register either of these to my smartphone's SIP client from the ITSP account and it will ring on my phone, and it functions without any difficulty so I know that in general terms my ITSP and DIDs are working, but when I set it up on the Quadro2X I can only make outgoing calls but incoming calls are rejected.

I have a newer Quadro2X device at a different client, and using the same ITSP and the extension setting from the VoIP Carrier Wizard are essentially the same, except for the account names and passwords etc.

I have tried various distributions setting to thie "VoIP Carrier" extension to
a. unconditionally forward calls on "Any Address" to a real extension,
b. or set MER on "Any Address" to various real extensions
c. Unconditionally fiorward to a virtual extension configured an MER group

The NAT Traversal settings are the same for both systems.

I have performed a factory reset, and built up both systems in pretty much the same way

I have even created a VPN connection to the client's network that has the Quadro2X that works, so that I cans xee if it is a networking issue such as a NAT traversal STUN problem, but all with the same results.

The call routing tables between both system is very very similar, all the same dial patterns, and just different account settings to reflect the different ITSP accounts. Incidentally the two Quadro's are independant of each other at the different end users.

Very curiously, and which is the only real hint as to what the problem is, is on the ITSP logs when a call is made to the DID there is an incoming call eg:

IN 23-Aug 10:59 AM 041117xxxx 029037x/70xxx ITSPname No Answer. 0s 0

and also a second outgoing entry at the same time!:

OUT 23-Aug 10:59 AM 70xxx 029037xxxx ITSPnamel No Answer. 0s 0

which would seem to be the cause of the problem. This does not happen with the other client system that is working. There is just the IN entry.

So it seems that the incoming entry is routing back out trying to connect to itself. If it was a call relaying problem I would have thought that there would have been four entries in the ITSP log rather than two as it tried to call the second extension, which is failover is the first is busy, so the two entries just confuse me more.

The not work Quadro2X's SIP UA Diagonostic log shows:

10:59:48 Receive SIP message # (23/08/2012 00:59:48:030 GMT) # UDP # 943 bytes # buff size 0 # from: 202.52.xxx..xxx:5060 # to: 27.253.xxx.xxx:5060

***************************** SIP message buffer start *****************************
INVITE sip:029037xxxx@27.253.xxx.xxx:5060 SIP/2.0
Via: SIP/2.0/UDP 202.52.xxx.xxx:5060;branch=z9hG4bK47e42566;rport
Max-Forwards: 70
From: "xxxxxxxxx xxxxx" <sip:041117xxxx@202.52.xxx.xxx>;tag=as0b19c657
To: <sip:029037xxxx@27.253.xxx.xxx:5060>
Contact: <sip:041117xxxx@202.52.xxx.xxx:5060>
Call-ID: 5a4d85632dbf7b824856244a45c72adf@202.52.xxx.xxx:5060
CSeq: 102 INVITE
User-Agent: ITSPname
Date: Thu, 23 Aug 2012 00:59:48 GMT
Supported: replaces, timer
Content-Type: application/sdp
Content-Length: 335

o=root 507643097 507643097 IN IP4 202.52.xxx.xxx
s=Asterisk PBX 1.8.xxx.xxx
c=IN IP4 202.52.xxx.xxx
t=0 0
m=audio 13676 RTP/AVP 8 18 0 101
a=rtpmap:8 PCMA/8000
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:0 PCMU/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=silenceSuppff - - - -
***************************** SIP message buffer end ******************************

10:59:48 Try to send SIP message # (23/08/2012 00:59:48:035 GMT) # UDP # 316 bytes # buff size 0 # from: 27.253.xxx.xxx:5060 # to: 202.52.xxx.xxx:5060

***************************** SIP message buffer start *****************************
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 202.52.xxx.xxx:5060;rport=5060;branch=z9hG4bK47e42 566
To: <sip:029037xxxx@27.253.xxx.xxx:5060>
From: "xxxxxxxxx xxxxx" <sip:041117xxxx@202.52.xxx.xxx>;tag=as0b19c657
CSeq: 102 INVITE
Call-ID: 5a4d85632dbf7b824856244a45c72adf@202.52.xxx.xxx:5060
Content-Length: 0

***************************** SIP message buffer end ******************************

For the system that is working the version are:
Quadro Operating system: 5.3.2 root@Delta.epygi.loc
Application Software: 5.3.2 - Release
Boot Loader: U-Boot 5.3.2/Release
DSP Software: Version: 5.3.2. Date: March 20 2012 21:05:41

for the one that uis not working:
Quadro Operating system: 5.3.5 root@delta.epygi.loc
Application Software: 5.3.5 - Release
Boot Loader: PPCBoot 4.0.8/Release
DSP Software: Version: 5.1.15.Date: Apr 23 2009 12:17

Does anyone have any idea what might be causing this?