Results 1 to 3 of 3

Thread: Can't register remote soft phone

  1. #1

    Default Can't register remote soft phone

    I am having trouble registering a softphone (Acrobits on the iPhone) on my Quadro from outside my local network. My Quadro sits behind a Draytek router on my local network, and I have opened SIP and RTP ports on the router directing SIP and RTP traffic to the Quadro. I have configured one of my extensions as a remote extension and configured it as per the "Quadro Remote Extension Configuration" guide available on the epygi site (the Remote Extension is enabled and the "Enable RTP Proxy" and the "Fallback to Local Extension When Not Registered" options are both ticked, while "Symmetric RTP" is not ticked).

    When my softphone is connected to my local network (i.e. the iPhone is connected to the local network via Wi-Fi on the LAN side of the router) and I configure the softphone with the domain showing the local IP address of the Quadro, the softphone connects fine. When I try to connect when I'm away from my local network (using the WAN address of the router as the domain, of course), the softphone won't register.

    As my router has VPN capability I can connect my remote softphone and get it to register by making a VPN connection from my iPhone to my router, but it's not really the functionality of the remote extension per se that I really need anyway (I never have much luck getting decent call quality when I connect the remote soft phone using VPN as my home broadband speed is lousy and not up to redirecting SIP traffic to a remote extension as well as handling the traffic to and from the party on the other end of the call). It is the functionality of the Acrobits softphone to use "Push Notifications" to inform me of an incoming call on the iPhone that I really need (to make this work the Acrobits push notification server apparently needs to be able to register remotely on my Quadro). Without Push Notifications enabled on the softphone I would have to use the softphone option to keep it alive on the iPhone to be able to answer incoming calls on the iPhone (I can make outgoing calls okay). The problem with keeping the softphone alive on the iPhone is that it drains the iPhone battery.

    I have tried adding ":5060" to the end of the WAN address in the softphone configuration, and I have also tried using the WAN address as the proxy in the softphone, but no combination I have tried seems to work. I thought the problem might have been the result of the fact that I have established a SIP Filtering Rule in the Quadro to only allow SIP traffic from my local LAN, but I disabled this temporarily and I still couldn't register.

  2. #2

    Default

    I would suggest to start from checking if Quadro gets any SIP registration message from iPhone. The registration messages are stored in the "sip_reg.log" file in Quadro system logs.

  3. #3

    Default

    I have the same problem and the same configuration, where do I find this log file?
    http://192.168.1.40/sip_reg.log is permission denied.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ip Blocker Not Working!!!!
    By rmiroslavov in forum Troubleshooting and Problems
    Replies: 6
    Last Post: 07-30-2012, 04:28 AM
  2. Suddenly no sip registration
    By keeskoets in forum Troubleshooting and Problems
    Replies: 21
    Last Post: 02-04-2011, 03:13 AM
  3. Hacker attempts
    By KSComs in forum General Discussions
    Replies: 51
    Last Post: 01-21-2011, 02:12 PM
  4. Account Time disconnect
    By valigetta in forum Troubleshooting and Problems
    Replies: 11
    Last Post: 04-16-2010, 11:08 AM
  5. Quadro looses registration to VoIP provider
    By gbakoc in forum Troubleshooting and Problems
    Replies: 6
    Last Post: 11-19-2009, 03:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •