Results 1 to 5 of 5

Thread: Failing to subscribe for call state change notifications

  1. #1

    Default Failing to subscribe for call state change notifications

    I am having problem with subscribing for notifications of call state changes. After sending request to Quadro2x:
    <?xml version="1.0"?>
    <methodCall>
    <methodName>>Services.CallProcessingService.subscr ibe</methodName>
    <params>
    <param>
    <value>
    <string>TYCO_13</string>
    </value>
    </param>
    <param>
    <value>
    <int>3</int>
    </value>
    </param>
    <param>
    <value>
    <struct>
    <member>
    <name>extension</name>
    <value>
    <string>13</string>
    </value>
    </member>
    </struct>
    </value>
    </param>
    </params>
    </methodCall>

    ... I am getting response (undocumented) like this:
    <?xml version="1.0"?>
    <?xml version="1.0"?>
    <methodResponse>
    <fault>
    <value><struct>
    <member>
    <name>faultCode</name>
    <value><int>1</int></value>
    </member>
    <member>
    <name>faultString</name>
    <value><string>Unknown XML RPC method</string></value>
    </member>
    </struct></value>
    </fault>
    </methodResponse>

    My Firmware Version: 5.2.48/Release.

    Any suggestions?
    Thanks,
    Janusz

  2. #2

    Default

    Hello,

    Your subscription ID is incorrect(TYCO_13).
    Use unique ID which contains only digits.

    Regards
    Tigran

  3. #3

    Default Failing to subscribe for call state change notifications

    Thanks for suggestion. I tried it by specifying 13 instead of TYCO_13 as a unique id like below:
    <?xml version="1.0"?>
    <methodCall>
    <methodName>>Services.CallProcessingService.subscr ibe</methodName>
    <params>
    <param>
    <value>
    <string>13</string>
    </value>
    </param>
    <param>
    <value>
    <int>3</int>
    </value>
    </param>
    <param>
    <value>
    <struct>
    <member>
    <name>extension</name>
    <value>
    <string>13</string>
    </value>
    </member>
    </struct>
    </value>
    </param>
    </params>
    </methodCall>

    And I am still getting this:
    <?xml version="1.0"?>
    <methodResponse>
    <fault>
    <value><struct>
    <member>
    <name>faultCode</name>
    <value><int>1</int></value>
    </member>
    <member>
    <name>faultString</name>
    <value><string>Unknown XML RPC method</string></value>
    </member>
    </struct></value>
    </fault>
    </methodResponse>

  4. #4

    Default

    Invalid xml format
    ...
    <methodName>>Services.CallProcessingService.subs cr ibe</methodName>
    ...

    double > after methodname

  5. #5

    Default Failing to subscribe for call state change notifications

    Thanks. You are right. It works now.
    Cheers,
    Janusz

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Notifications email subject enhancements
    By woods in forum Suggestions and Feedback
    Replies: 1
    Last Post: 12-08-2011, 02:54 AM
  2. voice message notifications
    By networthfs in forum Troubleshooting and Problems
    Replies: 1
    Last Post: 03-12-2008, 04:38 PM
  3. FXS port on unending Call state: Busy
    By todash in forum Troubleshooting and Problems
    Replies: 4
    Last Post: 08-19-2007, 04:49 PM
  4. Problems with SUBSCRIBE
    By MarkLL in forum Troubleshooting and Problems
    Replies: 0
    Last Post: 05-22-2007, 09:06 AM
  5. Transfers Failing on Quadro2x
    By mikehains in forum Troubleshooting and Problems
    Replies: 0
    Last Post: 11-20-2006, 04:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •