Results 1 to 4 of 4

Thread: Routing rule using DNS hostname not working

  1. #1

    Default Routing rule using DNS hostname not working

    I'm creating a routing rule to send calls from one Epygi unit to the other (route one site extensions to another).

    I'm unable to make a routing rule using a fully qualify dns hostname in the "Destination Host" field of the routing rule. If I enter an IP address in this field it works (which is what we currently use).

    From the documentation
    Destination Host text field indicates IP address or the host name of the destination (for direct call) or the SIP server (for calls through SIP server).
    However this does not appear to be the case.

    We are trying to fix up the few remaining things that are not fully DNS. The units were initially configure using IP address routing rule to get it up and going quickly.

    Steps I did are below:
    1) I create a new routing rule and select "IP-PSTN" as the "Destination Type"
    2) On the "Routing Call Settings"->Destination Host:" field I entered "" (hostname of the other Epygi unit) as the destination.
    3) go through the rest of the settings as per normal.
    4) Make a test call to that destination.
    5) get error "IP Conection cannot be established"!
    6)Go back to the rule and change the Destination Host: field to "192.168.x.123" (IP of the other Epygi unit)
    7) Test a again and it works with no problem.
    8) Change back to hostname again, no working!
    I have tried this on multiple units with the same result.

    The relevant version numbers are:
    Quadro M32x firmware version: 5.2.48 (which is the latest)

    I have tested to make sure the DNS hostname actually is able to be resolve by the epygi unit itself. I use the "Systems->Networking Tools" on the Epygi to ping the exact hostname (I entered in the routing rule) and it resolve and pings no problem).

    So looks like one part of the Epygi resolve it ok, while the other (routing) can't resolve it (or won't work with it).

    Anyone has try routing rule using DNS names? Am I doing this wrong?
    Last edited by woods; 01-11-2012 at 09:47 PM. Reason: spelling

  2. #2



    I'm using hostnames on the Call Routing Rules and never faced this type of issues.
    Anyway, to solve this issue you can try to enter mentioned hostname on the "Host Aliases for SIP" table.
    To do this:
    1. Connect to the second Quadro`s GUI (Quadro with "192.168.x.123" IP address);
    2. Go to the "Telephony"->"SIP Settings" page and click on the "Host Aliases for SIP" link;
    3. On the opened page press "Add" link, put "" hostname on the "Alias" field and Save this page.

    If it does not help, try to investigate the logs ("System"->"Diagnostics"->"Show System Logs" page) and understand:
    Does the first Quadro sends SIP messages to correct destination?
    Does the second Quadro receive these SIP messages?
    Why the second Quadro doesn't handle (reject) these messages?

    Finally, you can buy the support plan (1 ticket) and post the ticket on the Epygi support site. Do not forget to attach system logs of both Quadros. Just press "Mark all logs" button ("System"->"Diagnostics"->"Show System Logs"->"System Logs Settings" page), make problematic call, download logs from both Quadros and attach files on your request.
    I hope, Epygi support team will immediately find the source of your problem.


  3. #3



    Thank you for your reply, it lead me in the right direction

    After some deeper diagnostic through the logs and thinking about it some more I worked out what was needed and was missing.

    I did not know about the "Host Aliases for SIP" section or it use until you mentioned it (only RTFM when you need it ).

    At each of our site we have a dns entry which points to the correct Epygi (we have many Epygi). Naturally the Epygi (real) DNS did not match up with the hostname in the routing rule.

    So when Epygi A route a call to Epygi B via the dns alias, Epygi B rejects the call as it doesn't know that it is the aliased hostname.

    To route the call from A->B the aliased hostname (use in the routing rule on Epygi A) must be added into Epygi B "Host Aliases for SIP" list of alias so that it knows it is the aliased hostname.

    I guess if I had used the actual hostname of the Epygi B (in the routing rule) unit I would not have ran into this issue. We will be migrating some site from one Epygi to another that is why I am changing from IP to DNS as it will make the process easier to migrate (from a networking point of view).

    I would have though from a networking point of view, why it would matter if the hostname matched or not as DNS is only use to resolve to the IP and once that is turned into an IP address there is no need or care what the host name is? I could have a single host that can pretend (via DNS alias) to be many different PBX to many different customers / people. I'm guessing no one has done this trick before.

  4. #4
    Senior Member
    Join Date
    Oct 2008
    Melbourne, Australia


    Awesome. I think this may be solution to issue I posted 3 years ago.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How do I create a routing rule
    By Lumalac in forum General Discussions
    Replies: 2
    Last Post: 12-01-2011, 03:20 AM
  2. SIP Tunnel versus sip in routing rule
    By lambsons in forum Tips and Tricks
    Replies: 1
    Last Post: 08-31-2010, 03:58 AM
  3. Replies: 1
    Last Post: 09-08-2009, 09:52 PM
  4. Outbound call routing rule has stopped working
    By esscom in forum Troubleshooting and Problems
    Replies: 5
    Last Post: 05-06-2009, 10:14 AM
  5. Incoming call routing not working...
    By excellence-it in forum General Discussions
    Replies: 5
    Last Post: 03-10-2008, 03:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts