Results 1 to 3 of 3

Thread: Stun

  1. #1

    Default Stun

    I have 3 remote extensions with Snom phones and are working but some times i say very often when a call from one ext to another they apper to be register but they do not ring the send me to VM , what can i do so they will work better, they are all behind routers or nats
    if i activate stun which setting should i use ,? which is the server of stun,
    Stun.epygi.com ? or stun1.epygi.com and what port ? for the phones .

    Thanks for your help .

  2. #2
    Quadro Architect
    Join Date
    Jun 2006
    Location
    Around myself
    Posts
    2,075

    Default

    All those problems are definitely caused by NAT Traversal issues, but it's difficult to tell what exactly is the problem in your specific installation without seing the connection scheme and/or being on the site and checking all the connections.
    In general, there are three way to make sure remote extensions work correctly:
    1. Open static mappings on NAT servers - to map the SIP and RTP ports on the NAT router to be forwarded to appropriate ports on Quadro. The same ideally should be done on remote locations whenever possible - to map SIP and RTP ports on NAT servers to phone ports. I agree very often this is not an option at remote locations, as NAT servers may not be under your control. But IF they are under your control - it is worth to make those mappings.

    2. If the option 1 cannot be done, use stun whenever possible - on the Quadro, and on the remote locations. Stun server could be stun1.epygi.com:3478 or any other stun server in the net. This is mostly helpful not only to determine correct network addresses to use in SIP messages (which is the main STUN purpose), but also for keeping port mappings open on nat servers (see http://en.wikipedia.org/wiki/UDP_hole_punching).

    3. If you cannot do the option 1, and the option 2 helps but you still have problems (like phones becoming unreachable from time to time, like in the post above), in addition to steps above you can decrease the SIP registration timeout on the phones, so they send registration messages very often - for example every 3 minutes. This will help to keep the holes open on the NAT server. Typically NAT servers keep those holes open for about 3 minutes, and then if no traffic passes through then, close those holes. Making the registration period to be 3 minutes, you are "pinging" through those holes to keep them open. This will increase the load on devices, but my help to solve problems if nothing else helps.

    Hope this helps,
    David

  3. #3

    Default

    Thank You David,

    This Helps A lot , i try open the ports on the phone side SIP 5060, and RTP ?
    right now i have on the Quadro 2X open 5060 and 6000-6099 , and have activated RTP : Use STUN , what port range should i activate (OPEN) for RTP?(6000-6099) on the Quadro and which ones on the Phones? (The Same 6000-6099)?
    ( Just to be sure ...)
    it seem that i am on the right track just a little bit more help , would be greatly appreciated .
    should i activate RTP on the phones side will that help too?

    Thank you , Again
    Last edited by unitechsys; 09-29-2011 at 03:26 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Question] STUN port detection and Failed port
    By Celestix in forum Troubleshooting and Problems
    Replies: 6
    Last Post: 02-25-2010, 10:28 AM
  2. Connection Type [STUN/ NAT Traversal]
    By comstor in forum Troubleshooting and Problems
    Replies: 4
    Last Post: 04-11-2007, 09:39 PM
  3. STUN DOESN?T WORK VERY WELL
    By nortex in forum Tips and Tricks
    Replies: 3
    Last Post: 08-16-2006, 01:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •