Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Quadro 2x firmware for old 32MB h/w

  1. #1

    Default Quadro 2x firmware for old 32MB h/w

    Does anyone know what the lates firmware upgrade is for the old 32MB quadro 2x model is?

    I have version 5.1.39 and all the lates versions I can find are not suitable for the 32MB version so I am wondering if 5.1.39 is highest version for my old unit?

    Reason for looking is that we have switched provider to Gradwell in the UK and the voip calls are terrible quality so I thought I would check and see it the unit needs upgrading.

    Thanks!

  2. #2

    Default

    Re: switched provider to Gradwell in the UK and the voip calls are terrible quality

    This intimates till your change the system was working without problems and now you are having problems.

    New firmware if there was some for your system, wont rectify a problem with your new provider.

    K

  3. #3

    Default

    Thanks K.

    I wasn't using the IPBX to its full extent before.... just to relay voice mails by email.

    Having just moved office and not being able to move the tel number I thought I may as well use the Quadro properly. So I moved the old tel number to VOIP (Gradwell).

    I have just carried out a factory reset and set it up from scratch again. Unfortunately the problem still persists (the lost packet rate is very high).

    To check things further, I installed a soft phone on the PC connected direct to gradwell. This test uses the same router and modem but bypasses the quadro. The quality of the call was much better but there is still a little echo received by the calling party (could be due to using the built in mic and speaker causing some feedback).

    Both quadro and soft phone have been setup using the same sip server and nat details. So, it would seem that there is somthing in the quadro setup which is effecting the call quality and resulting in a high % packet loss.

    I really don't know what to do next. Any advise would be greatly appreciated.

    R

  4. #4
    Quadro Architect
    Join Date
    Jun 2006
    Location
    Around myself
    Posts
    2,075

    Default

    You may want to check if your softphone is using the same codec as the Quadro.
    Are you using analog phone with the Quadro or a SIP phone? Where do you see the packet loss details - is it shown on Quadro call statistics? If yes - then could you show the stats here?

  5. #5

    Default

    Thanks for your reply.

    I am using an analogue phone connected to the Quadro (DECT).

    The call statistics are on the Quadro. I will attach a screen dump of the stats.

    Thanks for your help


    RX Codec: PCMA
    Received Packets: 4730
    Received Packet Size: 160
    RX Lost Packets: 17301 (78.53%)
    RX Jitter: 15
    RX Maximum Delay: Undefined
    RX Delay Increase Count: 0
    RX Delay Decrease Count: 3
    TX Codec: PCMA
    Transmitted Packets: 4592
    Transmitted Packet Size: 160

  6. #6
    Quadro Architect
    Join Date
    Jun 2006
    Location
    Around myself
    Posts
    2,075

    Default

    Thats strange stats. The sent packets count is almost equal to the received paclets count, so that means there was probably no real packet loss. But then it is not clear what this 17301 "lost" packets could mean. It may happen that some device is sending another RTP stream to the same port, which causes those strange stats.

    Can you try to change the RTP port range on the Quadro (for example to 7000-7020), and make another call (show stats if needed)?

  7. #7

    Default

    I will give it a try and let you know how it goes.

    Thanks

  8. #8

    Default

    Thought I would quickly make the changes. I tried calling the line from my mobile, although the call seemed ok with no echo on the office phone the stats showed that 3 out of the 7 calls were very bad. I will continue to monitor the call quality on some real calls.

    RX Codec: PCMA
    Received Packets: 309
    Received Packet Size: 160
    RX Lost Packets: 16356 (98.15%)
    RX Jitter: 15
    RX Maximum Delay: Undefined
    RX Delay Increase Count: 48
    RX Delay Decrease Count: 2
    TX Codec: PCMA
    Transmitted Packets: 362
    Transmitted Packet Size: 160

  9. #9
    Quadro Architect
    Join Date
    Jun 2006
    Location
    Around myself
    Posts
    2,075

    Default

    There is another possibe reason for this kind of statistics. The ITSP may be sending an RTP stream, which has drastic "Sequence Number" (thats a field in RTP header) change in the middle of the stream at some point. This is a bad practice, but some ITSPs have habit to do that. If this is the case, there is nothing dangerous, as Quadro RTP stack handles such changes well, and they have no impact on voice quality (just the statiscitc is spoiled).
    Lets see how is the voice quality on real calls.
    If it is ok, then you have to ignore call stats (or contact the ITSP to fix that).

    If the quality is bad on some calls and is good on others, then I suppose this is the issue either with ITSP or your network connection (it is possible that the experiment which you did with softphone, was done during the "good" time - thats why the quality was good).

    If the quality is bad on all calls, then lets look further (you'll need to describe what you mean by bad quality - is there an echo, or clicks, or robotic voice, or dropouts in the conversation).

    Best regards,
    David

  10. #10

    Default

    Thanks for all your help with this problem..... I have to say that it has been very frustraiting.

    I will monitor the real calls, hopefully your RTP suggestion has solved the problem.

    Many thanks, Russ

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Quadro 4Li firmware
    By lambsons in forum General Discussions
    Replies: 2
    Last Post: 07-22-2010, 11:07 PM
  2. Quadro 4x Firmware
    By electrickflyer in forum Troubleshooting and Problems
    Replies: 1
    Last Post: 07-06-2010, 02:23 AM
  3. Quadro 5.1.21 firmware
    By woods in forum Announcements
    Replies: 2
    Last Post: 07-12-2009, 09:20 PM
  4. Quadro 16x - Firmware download
    By DuettoFavorit in forum General Discussions
    Replies: 1
    Last Post: 04-01-2009, 04:51 PM
  5. Firmware for Quadro 4xi
    By swenz in forum Hardware Interoperability
    Replies: 3
    Last Post: 09-03-2008, 12:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •