Results 1 to 8 of 8

Thread: Routing for incoming IP-pstn call

  1. #1

    Default Routing for incoming IP-pstn call

    I currently set my FXO incoming (main line) with Routing, say value "60050" and in CRT I use a few rules to validate the "60050" and send the call to the right AA (say 50, 51, 52) depending on the day/time by use of NDS and prefix. This works well. However, I cannot seem to find the equivalent for incoming call from IP-pstn, the only variable I can use is the unconditional call forward to the PBX extension. Is there an equivalent function that I can use to pass in the value "60050" from an incoming IP-pstn call to CRT just like in the FXO? This would make it more efficient to use one set of rules already in the CRT.

    Your assistance and comments are much appreciated.

  2. #2

    Default

    unconditional call forward to 60050

  3. #3

    Default

    Thanks for the quick response. Doing so with PBX and 60050 unconditional call forward for the IP-pstn incoming failed. The call did not terminate at the Quadro and went to the IP-pstn vmail. In CRT I have tried with and without checking the "Route all Incoming call to Call Routing" with Source Filter set to "Any" or other values.

    By inference, somehow, the incoming call could not be directed to 60050 on the Quadro and the IP-pstn vendor's vmail kicked in. Looks like the 60050 is not processed by the CRT compared to the FXO Routing. Perhaps I missed something very simple?

  4. #4

    Default

    try to set the "RTP Proxy" mode on call routing rule with 60050 pattern.

  5. #5

    Default

    Thanks. I checked and only in the VoIP wizard in CRT it allows for RTP Proxy setting but that is for outgoing calls via the nominated IP-pstn. For example, I have the "7" prefix to do an outgoing call on that VoIP line and the RTP Proxy is also checked.

    My objective is to have an incoming IP-pstn call pass the value 60050 to the CRT just like the FXO setting with Routing. I have tried using the value '60050' in the unconditional call forward for the extension associated to the IP-pstn line but this does not work.

    Can you please further explain your suggestion?

  6. #6

    Default

    Handling of the calls arrived from SIP trunk differs from handling the calls from FXO and there is no place in configuration to pass the value 60050 from SIP trunk to CRT. In general, the inbound calls from SIP are handled as follows.
    Upon receiving a SIP call, Quadro checks if the destination number (received with the SIP INVITE) message is assigned to any of Quadro extensions as a SIP user name. If it is, then the call is being connected to that extension. Otherwise, the call goes to CRT and Quadro tries to find the CRT record with the destination number pattern matching with the destination number received with the call. If a matching CRT record is found then the call is being routed according to that record. If the "Route all incoming SIP calls to Call Routing" is checked then Quadro skips the first step (trying to find the extension to connect the call to) and goes immediately to CRT. Now, back to your specific scenario.
    In my understanding, you've configured the FXO settings to send the incoming calls to "routing" to 60050 number. Also, you have the CRT records with 60050 destination number pattern. Thus, if you want to use the same records for calls from SIP, you can do the following. On virtual extension created by the VoIP Wizard, set the unconditional call forwarding to 60050 with "Auto" type. In CRT records having 60050 as a destination number pattern remove the "Source Filter". Also, disable the "Route all Incoming calls to Call Routing". With all this done, the calls from SIP will go to extension created by VoIP wizard and from there to CRT with destination number 60050. From this point on the call will be handled the same way as if it would come from FXO.

  7. #7

    Default

    Hi hrant, thanks for your explanation. The issue is now resolved but with some surprising observations.

    I did as suggested (value in unconditional call forward, AUTO, remove source filter) with "60050" rule and it failed like what I was getting before. Note that the "Route all incoming SIP calls to Call Routing" has always been unchecked. I then tried adding an entry with same attributes but for "650" and to my surprise it worked, even when I re-routed the FXO to the new '650' values.

    I re-tested switching back to "60050", i.e. existing rules in CRT and it failed like before on the SIP.

    I eventually changed this to "61050" (to distinguish as a non-extension) and all working good for SIP and FXO.

    Cannot explain why it failed on incoming SIP for existing CRT rule and why adding a 'new' rule made a difference. I suspect a re-boot might be required so after I have a need to re-boot the Quadro at a later stage, will re-test to see if that was the case. Explanations and suggestions given much appreciated.

  8. #8

    Default

    tsim: to apply the changes in Call Routing records the reboot is not needed at all.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 06-14-2010, 08:20 AM
  2. Replies: 0
    Last Post: 06-11-2010, 12:01 AM
  3. Incoming call routing question.
    By Leeinsa in forum 'How Do I' Questions
    Replies: 9
    Last Post: 04-28-2010, 03:28 PM
  4. Incoming call routing
    By peterd in forum General Discussions
    Replies: 10
    Last Post: 11-12-2009, 03:46 AM
  5. Routing Incoming PSTN calls to VOIP
    By mskinner in forum 'How Do I' Questions
    Replies: 4
    Last Post: 08-25-2006, 10:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •