Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Remote Extension issue

  1. #11



    In the last zip file you have attached SIP User Agent log. Previously attached .pdf is normal log, there is no any information about your failure. Try to reproduce SIP Registration failure and immediately download logs. Also try to set firewall security_level to LOW. A saw now firewall is MEDIUM.

  2. #12


    I have done some more tests.
    From what i can see, the softphone is not even getting to the Quadro.
    Strange that it has previously connected but since i have started getting these errors, it has not connected again.

    I connected the softphone to a local Quadro that we have here and it connects with no issues.
    I then changed the settings back to connect to the client Quadro and same error.
    I have disabled my local firewall, the firewall on the clients Quadro and even put the clients Quadro in a DMZ.
    Still getting the error.

    Have i missed a port to forward to the Quadro?
    I am currently forwarding the following ports and protocols to the Quadro:
    5060 - TCP & UDP
    80 - TCP
    6000 to 6099 - TCP & UDP

    I have also attached another log from the softphone when i connected to the local Quadro and then tried to connect to the client's Quadro.
    Attached Files Attached Files

  3. #13


    Ross, it might be the router that you are using.

    What is the brand and firmware of it ?

    I have found that it can be hit and miss with them, and sometimes the only way is to down/upgrade firmware to resolve the issues that you appear to be facing.

    I have a Linksys router that fails on the latest firmware, but older firmware where SIP wasnt broken is fine. The manufacturer decided to block 5060 udp and only allow tcp 5060 in firmware.

    So is it a firewall causing the problem ? are the 2 x routers exactly the same ?

    It might even be that your clients ISP has decided to block ports and could be the culprit.

    Any way ... hang in there .. I am sure there will be an answer to your problem soon.



  4. #14


    Hi Ross,

    I still think that SIP message "Bad Request" you got is not from Quadro. You can see in you attached log, that Quadro indictes it's User-Agent in it's massages. There is another account registered on Quadro. You can see that Quadro really indicates that. I have the impressions that massages are not getting the device and there is something wrong on your forwarding. Try to capture Quadro`s WAN interface, to be sure that Quadro gets messages. In that case, download the logs from Quadro, not from X-Lite.


  5. #15


    I have a feeling that KSComs might be on to something.
    Being that of all the tests that i have done have shown that the Quadro isnt even getting the registration package, i am begining to think that the router/firewalls are the issue.

    The router with the Quadro is the following:
    Model Name : Vigor2820Vn
    Firmware Version :
    Build Date/Time : Jul 24 2009 16:46:32

    I will need to find out from my client what the router on the other end is.

    I somehow doubt that the ISP is blocking the ports, being that the ISP is a VOIP supplier and the line is used for VOIP.
    At this point, im more leaning towards the router issue.

    As for the logs and seeing the other Agent Registrations, they are local VOIP users on local extensions, which is working fine with no major issues.
    What i am working with is, at the moment, a single remote phone.

    Thanks for the information, i will have a talk to the client and see what happens.
    If i find a resolution for this, i will post it so that it can help anyone else in the future.

  6. #16


    Looks like i have found the issue.
    It appears that the Draytek is causing the issue.
    Being that it has its own SIP, it has taken over port 5060 for external use.
    Appears that this is a bug with some routers including Draytek's.
    From what i have found, there is a work around but requires changing the provisioning port to something other than 5060.

    Thanks everyone for your insight.
    Looks like my client will need to get themselves a new router to resolve this issue.

  7. #17


    Hi Ross

    Quote Originally Posted by Ross View Post
    Are you sure that Bad Request replay comes from quadro?
    Nice to know that problem is solved.


  8. #18


    Seems its going from one issue to another.
    Phone now registers and can make a call but no voice is transmitted and eventually the connection drops.
    Makes me wonder if i will ever get this working.

  9. #19



    I think the thing is in NAT Traversal settings. Try to make correct configuration of NAT.


  10. #20


    Looks like i am going to have some fun working this one out.
    Anyone have any ideas how i can test the NAT Transversal.
    Piece of software would be nice, if there is one.
    Trying to work out what type it is currently is fun with all the variables.

    Much appreciate all the help that you guys have given me so far.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Remote Extensions Registration/Setup Issue
    By ssajjad in forum Troubleshooting and Problems
    Replies: 5
    Last Post: 05-22-2010, 09:22 PM
  2. Remote Extension
    By abdulrhmanbm in forum Troubleshooting and Problems
    Replies: 9
    Last Post: 12-24-2009, 01:46 PM
  3. Remote Extension w. NAT
    By mya in forum Troubleshooting and Problems
    Replies: 1
    Last Post: 12-08-2009, 11:59 AM
  4. Incorrect remote address (DNS issue?)
    By lunacom in forum Troubleshooting and Problems
    Replies: 1
    Last Post: 02-06-2008, 01:54 AM
  5. Quadro 2x extension SIP registration issue.
    By paulk in forum 'How Do I' Questions
    Replies: 3
    Last Post: 02-04-2008, 07:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts