Results 1 to 2 of 2

Thread: FXO port fails diagnostic test – PSTN line is good

  1. #1
    Junior Member
    Join Date
    Dec 2008
    Location
    Melbourne, Victoria - not Florida.
    Posts
    14

    Unhappy FXO port fails diagnostic test – PSTN line is good

    On Sunday I took my 2x (FW 5.1.38, language AU 5.1.1) to a client to swap out for her unit, that’s giving me (and her) some problems – knowing that mine is good.

    After a hard reset and setting it up from scratch, its still exhibiting the same problem (but not I my LAN), which I’ll save for another post.

    The bigger problem is when an outbound call was made, it would randomly make it through the FXO port and not through the VOIP service – there is no pattern to this, about half the calls go over the PSTN line and half over VOIP!

    As part of what I was doing I checked the FXO port / PSTN line was working and found I could not make a call and got the “Please check your external line” message, it was then that I went in to System Diagnostics – Start FXO Diagnostics and I got this:

    FXO Tests:
    Test failed, no active FXO line found
    Error occured. Test is not completed.
    From the FXO Agent log I’ve got:

    03/15/201013:07:25
    Fxo_Line0 <0, 0>: Message from DSP, OnStateChange.
    Fxo_Line0 <0, 0>: In OnStateChange(), WaitForConfirmOffHook - 0.
    Fxo_Line0 <0, 0>: ERROR: In OnStateChange(), Nothing is expected.


    This is the same on my clients PSTN line and mine, and a phone works if plugged in to the line.

    I really hope that this is not a sign that the 2x’s FXO port is buggered.

    Your enlightenment would be appreciated.

    Francois

  2. #2
    Quadro Architect
    Join Date
    Jun 2006
    Location
    Around myself
    Posts
    2,075

    Default

    Well, it is not clear what your problem is: 1) system makes calls through FXO instead of IPPSTN; or 2) system cannot make any call through FXO...?
    I suppose there coul not be both problems at the same time, right?

    The first problem could be due to wring config in routing table... Do you have "Restriction on the Number of Simultaneous Calls" on the ITSP routing rule?

    The second one maybe due to wring country setting on the unit. Depending on the country setting, the telco lines are setup differently.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 05-21-2009, 01:25 PM
  2. Calls From PSTN to a FXO line do not show PSTN number
    By carlosmenem in forum 'How Do I' Questions
    Replies: 1
    Last Post: 12-05-2008, 11:33 AM
  3. 2 IP-PSTN line
    By sgroulx in forum 'How Do I' Questions
    Replies: 2
    Last Post: 11-11-2008, 09:58 AM
  4. Low voice sound from pstn line
    By MEDIAPCSYSTEM in forum Troubleshooting and Problems
    Replies: 15
    Last Post: 09-22-2008, 06:04 AM
  5. SMTP test mail fails
    By mobidutch in forum Troubleshooting and Problems
    Replies: 2
    Last Post: 03-17-2008, 09:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •