Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Find Me Follow Me / 2 Issues

  1. #1

    Default Find Me Follow Me / 2 Issues

    Hello everyone.

    2 issues with the Find Me Follow me features. We have a Quadro 4x (4xFXO) system. 4 lines with a local telephone provider, and 1 vonage softline programmed into the system.

    ISSUE 1:
    When the FMFM service is enabled and using the FXO lines to baiscally conference a call between the inbound line and the outbound calling line, the volume is drastically low. It is so low they can barely hear the inbound caller. We currently have them being forwarded to cell phones, but we have tried forwarding to standard land lines, and the same issue exists. Is there any way to increase the volume when teh FMFM services conferences the calls together? Call volume on regular calls from Quadro to cell or land line users is fine. It is only when the FMFM service conference the calls do we get the drastic volume issue. Lines has been individually tested for correct polarity and confirmed that there are no other devices on them. In addition, lines are clear, no static, interference or humms.

    ISSUE 2:
    When attempting to configure the FMFM service to use the Vonage IP line to dial the outbound portion of the call, it will fail to Call. The call log indicates "Autorization". We use the VoIP line for all other functions (Call redirects, etc...) and we have no problems. The VoIP lines works flawlessly for inbound and outbound calling, but does not function as the outgoing leg for the FMFM service.

    Your input would be greatly appreciated.

    Thanks

  2. #2
    Quadro Architect
    Join Date
    Jun 2006
    Location
    Around myself
    Posts
    2,075

    Default

    Hello

    the first issue cannot be related to FMFM service, as FMFM does not do anything specific when calling out - it call using the same mechanisms, as normal extension.
    So the problem most probably will happen always when both the caller and the called party is PSTN. You can check that by using Forwarding (UCF) instead of FMFM. If you call from PSTN, then forward (or tranfser) the call to another PSTN phone, the volume again will be low on your system.

    To increase that, you would need to play with FXO gains a bit. Try to increase RX and/or TX gains on FXO lines using "Telephony"->"Gain Control" webpage. Important: be extremely careful, as increasing gains may bring to echo!! You can increase one of the gains a little bit (for example from 6 to 9), and test if the volume is better, and if you have echo or not. If there is no echo, you can increase a bit more and test again.

    Related to issue 2: how do you configure the FMFM to call to Vonage? Do you use "Auto" or "SIP"? If you use "SIP", the call will be definitely rejected by authorisation error, as the system doesn't use the account username/password in that case. Use "Auto" and enter the destination number in the same way, as you dial it from a extension phone.

    Best regards,
    David

  3. #3

    Default

    Hi davrays ... thanks for the feed back.

    ISSUE 1: I tried the unconditional call forwarding, and you are correct ... the volume issue is present. I went to the Gain Control page, and on the FXO lines, I can only increse the gain on the RECIEVE side. Default is 6, and pumped it up to 12 ... no effect. on the Transmit side, the default is 0. The drop down only allows for -3 and -6, which is the opposite direction we want to go. Would there be another location to increase the gains? I am also calling the phone company to have the levels on these lines checked out. Other than that, would you think that a PSTN line amplifier may have any benefit?

    ISSUE 2: I have the Vonage line setup using the "8" prefix (all other lines are using "9"). I have successfully used the vonage line with UCF without a problem. The line is programmed as AUTO. It just doesn't work with the FMFM feature.

    Your comments area always appreciated.

    Thanks,

  4. #4
    Quadro Architect
    Join Date
    Jun 2006
    Location
    Around myself
    Posts
    2,075

    Default

    Well, the amplifier should help, but first we need to understand why increasing gain didn't help.. Did you notice any difference in call volume, after increasing the gain to 12? I mean - is the volume higher, but still not eenough, or there was absolutely no difference? In tha latter case, in may worth to reboot the Quadro (I am not sure but, it might help)... There should be some difference, unless there is a bug there - thats why I am asking this..

    To understand what happens with Vonage forwarding, we need to look into SIP messaging. Can you copy here the call flow between the Quadro and Vonage for the call done by FMFM (starting from the INVITE message up to the last authorisation failure message received from the Vonage)?

    Best regards
    David

  5. #5

    Default

    Hi davrays ...

    ISSUE 1: There was no percievable difference between the default setting of 6 and when increased to 12. I did a reboot of the Quadro, but no effect. I think this may be a line issue. I have placed a call into the provider to request the levels be checked.

    ISSUE 2: Please see the SIP log below.

    ***************************** SIP message buffer end ******************************

    11:22:14 CM --> UA # MakeCall # from: 4166286172, to: 4168168676@sphone.vopr.vonage.net:5061, media exist # replaceSID: 0 # privacy: 0 # AlertInfo: not exist # AddInfo: [NP#0:60] anonymous not exists #OID: 413 # SID: 31960286168935588
    11:22:14 SipSessDlg::CMOnMakeCall # Privacy is on , but without enough info.
    11:22:14 Try to send SIP message # (09/02/2010 16:22:14:451 GMT) # UDP # 991 bytes # buff size 0 # from: xxx.xxx.xxx.xxx:5060 # to: 216.115.20.41:5061

    ***************************** SIP message buffer start *****************************
    INVITE sip:4168168676@sphone.vopr.vonage.net:5061 SIP/2.0
    Via: SIP/2.0/UDP xxx.xxx.xxx.xxx:5060;rport;branch=z9hG4bKEPSVBUS27 6b0979-0036-404e-81d0-6f77ed42b21b
    To: <sip:4168168676@sphone.vopr.vonage.net>
    From: "4166286172" <sip:4166286172@sphone.vopr.vonage.net:5061>;tag=1 26573059501afa550-8bd0-4987-8ccf-c09dd1136157
    CSeq: 833 INVITE
    Call-ID: 31960286168935588_f8ad73aa-a519-4e87...TR.parner.local
    Allow: INVITE, ACK, CANCEL, BYE, OPTIONS, INFO, SUBSCRIBE, NOTIFY, REFER, MESSAGE, UPDATE
    Contact: "4166286172" <sip:4166286172@xxx.xxx.xxx.xxx:5060>
    Content-Type: application/sdp
    Supported: replaces, norefersub
    User-Agent: Epygi Quadro SIP User Agent/v5.1.30 (QUADRO-4X/16X)
    Max-Forwards: 70
    Content-Length: 248

    v=0
    o=- 592 359 IN IP4 xxx.xxx.xxx.xxx
    s=-
    c=IN IP4 xxx.xxx.xxx.xxx
    t=0 0
    m=audio 6022 RTP/AVP 0 8 18 101
    a=rtpmap:0 PCMU/8000
    a=rtpmap:8 PCMA/8000
    a=rtpmap:18 G729/8000
    a=fmtp:18 annexb=no
    a=rtpmap:101 telephone-event/8000
    a=fmtp:101 0-15
    ***************************** SIP message buffer end ******************************

    11:22:14 Receive SIP message # (09/02/2010 16:22:14:515 GMT) # UDP # 573 bytes # buff size 1 # from: 216.115.20.41:5061 # to: xxx.xxx.xxx.xxx:5060

    ***************************** SIP message buffer start *****************************
    SIP/2.0 407 Proxy Authentication Required
    Via: SIP/2.0/UDP xxx.xxx.xxx.xxx:5060;rport;branch=z9hG4bKEPSVBUS27 6b0979-0036-404e-81d0-6f77ed42b21b
    From: "4166286172" <sip:4166286172@sphone.vopr.vonage.net:5061>;tag=1 26573059501afa550-8bd0-4987-8ccf-c09dd1136157
    To: <sip:4168168676@sphone.vopr.vonage.net>;tag=108424 5294
    Call-ID: 31960286168935588_f8ad73aa-a519-4e87...TR.parner.local
    CSeq: 833 INVITE
    Proxy-Authenticate: Digest realm="216.115.20.41", domain="sip:216.115.20.41", nonce="221331091", algorithm=MD5
    Max-Forwards: 70
    Content-Length: 0

    ***************************** SIP message buffer end ******************************

    11:22:14 Try to send SIP message # (09/02/2010 16:22:14:520 GMT) # UDP # 536 bytes # buff size 1 # from: xxx.xxx.xxx.xxx:5060 # to: 216.115.20.41:5061

    ***************************** SIP message buffer start *****************************
    ACK sip:4168168676@sphone.vopr.vonage.net:5061 SIP/2.0
    Via: SIP/2.0/UDP xxx.xxx.xxx.xxx:5060;rport;branch=z9hG4bKEPSVBUS27 6b0979-0036-404e-81d0-6f77ed42b21b
    To: <sip:4168168676@sphone.vopr.vonage.net>;tag=108424 5294
    From: "4166286172" <sip:4166286172@sphone.vopr.vonage.net:5061>;tag=1 26573059501afa550-8bd0-4987-8ccf-c09dd1136157
    CSeq: 833 ACK
    Call-ID: 31960286168935588_f8ad73aa-a519-4e87...TR.parner.local
    User-Agent: Epygi Quadro SIP User Agent/v5.1.30 (QUADRO-4X/16X)
    Max-Forwards: 70
    Content-Length: 0

    ***************************** SIP message buffer end ******************************

    11:22:14 Got 407 response, try to authenticate message # OID: 413 # SID: 31960286168935588
    11:22:14 Try to send SIP message # (09/02/2010 16:22:14:534 GMT) # UDP # 1189 bytes # buff size 0 # from: xxx.xxx.xxx.xxx:5060 # to: 216.115.20.41:5061

    ***************************** SIP message buffer start *****************************
    INVITE sip:4168168676@sphone.vopr.vonage.net:5061 SIP/2.0
    Via: SIP/2.0/UDP xxx.xxx.xxx.xxx:5060;rport;branch=z9hG4bKEPSVBUS44 32af5d-bee3-44cf-a503-13c821eaa03b
    To: <sip:4168168676@sphone.vopr.vonage.net>
    From: "4166286172" <sip:4166286172@sphone.vopr.vonage.net:5061>;tag=1 26573059501afa550-8bd0-4987-8ccf-c09dd1136157
    CSeq: 834 INVITE
    Call-ID: 31960286168935588_f8ad73aa-a519-4e87...TR.parner.local
    Allow: INVITE, ACK, CANCEL, BYE, OPTIONS, INFO, SUBSCRIBE, NOTIFY, REFER, MESSAGE, UPDATE
    Contact: "4166286172" <sip:4166286172@xxx.xxx.xxx.xxx:5060>
    Content-Type: application/sdp
    Supported: replaces, norefersub
    User-Agent: Epygi Quadro SIP User Agent/v5.1.30 (QUADRO-4X/16X)
    Max-Forwards: 70
    Proxy-Authorization: Digest realm="216.115.20.41",nonce="221331091",username=" 4166286172",uri="sip:4168168676@sphone.vopr.vonage .net:5061",algorithm=MD5,response="1d1f7950322cc73 94296c83e8acb5f20"
    Content-Length: 248

    v=0
    o=- 592 359 IN IP4 xxx.xxx.xxx.xxx
    s=-
    c=IN IP4 xxx.xxx.xxx.xxx
    t=0 0
    m=audio 6022 RTP/AVP 0 8 18 101
    a=rtpmap:0 PCMU/8000
    a=rtpmap:8 PCMA/8000
    a=rtpmap:18 G729/8000
    a=fmtp:18 annexb=no
    a=rtpmap:101 telephone-event/8000
    a=fmtp:101 0-15
    ***************************** SIP message buffer end ******************************

    11:22:14 Receive SIP message # (09/02/2010 16:22:14:596 GMT) # UDP # 573 bytes # buff size 1 # from: 216.115.20.41:5061 # to: xxx.xxx.xxx.xxx:5060

    ***************************** SIP message buffer start *****************************
    SIP/2.0 407 Proxy Authentication Required
    Via: SIP/2.0/UDP xxx.xxx.xxx.xxx:5060;rport;branch=z9hG4bKEPSVBUS44 32af5d-bee3-44cf-a503-13c821eaa03b
    From: "4166286172" <sip:4166286172@sphone.vopr.vonage.net:5061>;tag=1 26573059501afa550-8bd0-4987-8ccf-c09dd1136157
    To: <sip:4168168676@sphone.vopr.vonage.net>;tag=201999 792
    Call-ID: 31960286168935588_f8ad73aa-a519-4e87...TR.parner.local
    CSeq: 834 INVITE
    Proxy-Authenticate: Digest realm="216.115.20.41", domain="sip:216.115.20.41", nonce="1416937562", algorithm=MD5
    Max-Forwards: 70
    Content-Length: 0

    ***************************** SIP message buffer end ******************************

    11:22:14 Try to send SIP message # (09/02/2010 16:22:14:601 GMT) # UDP # 535 bytes # buff size 1 # from: xxx.xxx.xxx.xxx:5060 # to: 216.115.20.41:5061

    ***************************** SIP message buffer start *****************************
    ACK sip:4168168676@sphone.vopr.vonage.net:5061 SIP/2.0
    Via: SIP/2.0/UDP xxx.xxx.xxx.xxx:5060;rport;branch=z9hG4bKEPSVBUS44 32af5d-bee3-44cf-a503-13c821eaa03b
    To: <sip:4168168676@sphone.vopr.vonage.net>;tag=201999 792
    From: "4166286172" <sip:4166286172@sphone.vopr.vonage.net:5061>;tag=1 26573059501afa550-8bd0-4987-8ccf-c09dd1136157
    CSeq: 834 ACK
    Call-ID: 31960286168935588_f8ad73aa-a519-4e87...TR.parner.local
    User-Agent: Epygi Quadro SIP User Agent/v5.1.30 (QUADRO-4X/16X)
    Max-Forwards: 70
    Content-Length: 0

    ***************************** SIP message buffer end ******************************

    11:22:14 Got 407 response, try to authenticate message # OID: 413 # SID: 31960286168935588
    11:22:14 UA --> CM # ReportError # Error: Authorization # Sip error: 0 # SID: 31960286168935588
    11:22:14 UA --> CM # ReportError # Error: Authorization # Sip error: 407 # SID: 31960286168935588

  6. #6

    Default

    Hi,

    From: "4166286172" <sip:4166286172@sphone.vopr.vonage.net:5061>;tag =1 26573059501afa550-8bd0-4987-8ccf-c09dd1136157

    Is this your Vonage Number 4166286172 or the number of the caller being forwarded?

    If its the caller, it maybe that Vonage wont accept a number it does not know about, to get around this you will have to go into the routing table entry.

    Under Source Filter / Modify Caller ID

    Source Number Pattern: *
    Source Type Try PBX first if not you may have to use AUTO.

    Callier ID Modification

    Number of Discarded symbols: 99
    Prefix : 1234567890 <-- your vonage Number, the 99 throws away any possible source number and replaces it with your Known number.

    Rest of the Fields can be blank.

    =================

    Try it out. I have never used Vonage however I have encountered this before.

    Hope it helps.

  7. #7

    Default

    Hi Zarf! ... the 4166286172 number happens to our vonage line here at our office. So in essence, you're seeing a Vonage to Vonage scenario. I am trying now from a land line to see whap happens.

  8. #8

    Default

    Same thing ... I am going to implement your suggested changes and report back.

  9. #9

    Default

    Hi Zarf!

    Your suggestions unfrotunately did not yield any results.

    However, I did discover an interesting work around. I created extension (600) with a UCF to the target number (using 8 as the prefix to use the VoIP line). Confirmed that this worked (as it has in the past without any problems). Then, in the FMFM feature, instead of having that module dial the target phone number, I had it dial PBX ext 600. I had to attach 600 to an IP line that is not used in order for this to work. The FMFM feature then worked flawlessly. I then applied this same work around for the Call Hunting feature, and it also worked well.

    I don't know specifically why using a direct phone number target fails, but not with the UCF rule. Does the FMFM use a different mechanism than the UCF for initiating the call on the SIP side? (I tried both AUTO and SIP versions of the dialing rule, and they both failed).

    With the above work around, the volume is now much much better, since I am not using a second PSTN line to make the call to the target number. I am trying to avoid PSTN to PSTN for the FMFM service, since the volume is a real problem. This work around buys my time and increases customer satisfaction.

    Thanks,

  10. #10
    Quadro Architect
    Join Date
    Jun 2006
    Location
    Around myself
    Posts
    2,075

    Default

    Hi ontapp

    I am glad you found a workaround, but the problem here is - this actually should not work... Quadro's "Call Hunting" cannot work for sure the way you described, unless your Quadro has gained its own uniqie brain and is self-developing . The UCF on the target extensions of Call Hunt group is completely ignored, so it just cannot work. Please test that again with some other caller/called number...

    What relates to FMFM.. this is not so impossible, but still I cannot really understand how this could work.. Does Vonage request authorisation for that call?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Find me - follow me calling
    By threebit in forum Suggestions and Feedback
    Replies: 5
    Last Post: 08-06-2012, 11:37 AM
  2. French in findme/follow me
    By serviplexSIP in forum Language Packs
    Replies: 6
    Last Post: 11-28-2010, 01:17 PM
  3. Find last firmware in a the website ?
    By Roguen in forum 'How Do I' Questions
    Replies: 3
    Last Post: 03-25-2010, 05:05 PM
  4. Follow Me / Find me "call ended"
    By mgenee in forum Troubleshooting and Problems
    Replies: 5
    Last Post: 02-24-2010, 08:05 AM
  5. Find Me / Follow Me - "User Not Found"
    By mya in forum Troubleshooting and Problems
    Replies: 1
    Last Post: 02-03-2010, 03:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •