Results 1 to 8 of 8

Thread: EMS Problem

  1. #1

    Default EMS Problem

    Installed EMS on cutomer site. Program loaded on computer with mp3 file and streaming to port 32686 on their epygi. EMS shows that it is streaming, but don't hear anything when call placed on hold. RTP Streaming channel and EMS port match, Tried pointing EMS to both external IP of the PBX and Internal IP, same result. Is there any other settings either on the computer, or perhaps the firewall ( not useing epygi firewal) that could be blocking the stream?
    Computer has windows XP OS

  2. #2
    Quadro Architect
    Join Date
    Jun 2006
    Location
    Around myself
    Posts
    2,075

    Default

    Theoretically windows firewall could block the stream. But it never happened on my PC...
    You would need to run network capture (hidden "netcapture.cgi") to see if the stream reaches the Quadro.

    Did you configure "Listen Hold Music"=Own_Music with "RTP Channel" set to correct channel on the extensions "Hold Music Settings"?

  3. #3

    Default

    Can't seem to opent he .cap file. What program do you use to open it? I tried with microsoft network monitor.

  4. #4

    Default

    Never mind, opened it with wireshark, I see the stream, but still no sound. I have the .cap files if you want to see them, I'm still not completely sure of everything I am seeing in them. I have 2, one with no call on hold, one with a call on hold

  5. #5
    Quadro Architect
    Join Date
    Jun 2006
    Location
    Around myself
    Posts
    2,075

    Default

    Well, it may worth to look into those CAP files. I sent you my mail address via PM, so you can send them in a mail, if they are too big to attach here.
    Also please specify in the same mail the following:
    1) the IP of machine with EMS;
    2) the IP of Quadro;
    3) the port you specified on Quadro for that channel.

    Best regards,
    David

  6. #6

    Default

    Thanks. As always you rock.

  7. #7
    Quadro Architect
    Join Date
    Jun 2006
    Location
    Around myself
    Posts
    2,075

    Default

    I got your mail Also someone from your team has opened a TSS ticket and attached the CAPs with logs Guys have answered you already, giving part of the info below.

    We looked on CAPs and it seems like you have activated the streaming hold music
    on the "holder", but not on the "holded" party.

    You have a call between local IP phone and remote destination. If the remote party holds the local one, you will surely listen the music on local IP phone.

    But I can see that the local party has put the remote one on hold, so you are probably expecting the remote party to listen music. That will not happen so easily

    For the remote side to listen hold music, two conditions should be met:
    1. Quadro should send that music out.
    2. the reemote side should be prepared to listen your mussic, instead of its own music

    For the (1) you need to set the "Send music to remote party" check box.
    For the (2) you need to configure the remote party to behave the way you need (if that is not the default behaviour for their equipment). If that is impossible, you would probably need to try the "Force Hold Music" checkbox on the hidden "generalconfig.cgi".

    And one more advice personally from me - it looks like you use the EMS from the LAN side of the Quadro. In that case you may have some stream interruptions, because the traffic prioritization mechanism closes that interface from time to time for anything except the IP phone traffic. So it is better to stream the music from WAN side, or use hidden "lantable.cgi" to add the streaming server's IP there. In future releases we will probably do that automatically, but now (on current releases) you would need to take this info into account.

    Best regards,
    David

  8. #8

    Smile

    IT WORKED!!!!! You are the man...Thank you and your team for me please!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •