Results 1 to 3 of 3

Thread: Annoying ISDN Problem

  1. #1

    Default Annoying ISDN Problem

    Hi,

    we have a problem in a new installation... i think is a low level ISDN problem but... I try here... hoping anyone have seen a similar problem, maybe i resolve playing with isdn advanced config.
    Behaviour is: External call arrive, extension ring but call is immediately dropped; in some case external caller ear a "number not reachable".

    I attach some lines of ISDN L3 log:
    09:35:39.861 ----> USER DATA 0 LINK LAYER IS CONNECTED
    09:35:52.650 CHNUM = 1
    .652 Isdn931UserAgent::SendMakeCallToCM TRUNK - 0, TS - 1, CR - 54
    .813 User Timer 0x32 timeout TRUNK - 0, TS - 1
    .855 Isdn931UserAgent::OnRinging TRUNK - 0, TS - 1, callID - 70871117912994265, addWParam - 0x0
    09:35:54.610 ----> USER DATA 0 LINK LAYER IS DISCONNECTED
    .611 Isdn931UserAgent::SendReportErrorToCM TRUNK - 0, TS - 1, CallID - 70871117912994265, reason - ISDN : Release from Layer2
    .612 SendReportErrorToCM : CallErrorCode - 0x6, IsdnErrorCode - 0x10
    .613 Isdn931UserAgent::SendReportErrorToCM : CloseCall

    Here some of ISDN L2:

    09:35:39.749

    ProcessMPH TRUNK = 0
    .750 ----- Isdn921Agent::GetLinkStatus : LINK 0 is UP -----
    .751 Link 0 is activated
    .752 Removing user : trunk,sapi,tei (0,0,-1)
    .757 Adding user : trunk,sapi,tei (0,0,-1)
    .758 TEI ASSIGN request
    .760 IsdnTimerProcessing : Get ISDNL2_TIMER_PROCESSOR_RESUME
    .809 ASSIGN response, TEI - 65
    .810 ASSIGNED, TEI - 65
    .859 AE_UA
    .863 IsdnTimerProcessing : Goto ISDNL2_TIMER_PROCESSOR_SUSPEND
    .909 MDL_ERR_A: received unsolicited response - supervisory ( F=1 )
    .911 IsdnTimerProcessing : Get ISDNL2_TIMER_PROCESSOR_RESUME
    09:35:52.713 DL_SETLEDS
    .714 DL_SETLED 1, on_off 1
    .734 DL_SETLEDS
    .735 DL_SETLED 2, on_off 0
    .749 ASSIGN response, TEI - 66
    .769 ASSIGN response, TEI - 67
    09:35:54.616 DL_SETLEDS
    .617 DL_SETLED 1, on_off 0
    .630 IsdnTimerProcessing : Goto ISDNL2_TIMER_PROCESSOR_SUSPEND
    .636 DL_SETLEDS
    .637 DL_SETLED 2, on_off 0

    If anyone have any suggestion...

    Regards, Lunacom.

  2. #2

    Default

    Hi Lunacom,

    It is difficult to find out the problem with developer logs disabled.
    The ISDN L1/L2/L3 problem might be connected with your environment. Seems you have few ISDN devices connected to the same ISDN bus and does not configured MSN.
    It will be fine if you can attach ISDN L2 logs with developer logs enabled so I may
    get the real reason of the problem.

    Artur

  3. #3

    Default

    Hi,

    problem seem to be resolved with replacement of NT1 interface...
    I take developers logs if issue reappears...
    Thanks.

    Regards, Lunacom.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Isdn
    By cornepiek in forum General Discussions
    Replies: 3
    Last Post: 04-25-2011, 06:59 AM
  2. Quadro ISDN how to
    By rwalland in forum 'How Do I' Questions
    Replies: 2
    Last Post: 11-04-2009, 07:52 AM
  3. ISDN - who's calling me?
    By ccomley in forum 'How Do I' Questions
    Replies: 26
    Last Post: 09-29-2008, 02:45 PM
  4. Search term minimum character limit is ANNOYING!!
    By stakano in forum General Discussions
    Replies: 1
    Last Post: 01-08-2008, 02:46 AM
  5. FAX from ISDN
    By becike in forum Troubleshooting and Problems
    Replies: 2
    Last Post: 12-20-2007, 02:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •