Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Remote extension one way audio

  1. #1

    Thumbs down Remote extension one way audio

    Hi I have recently upgraded a Quadro 16xi to version 5.1.30. I was running V 5.1.19 previously. I had remote extensions configured & working. Since upgrading the remote extensions are not working as well as prior to the firmware upgrade. I have set up VPNs from the remote sites to the Quadro. the client can call from the remote extension to IP handsets in the office. When you call analogue handsets you cannot here anyone who answers the phone. I have pasted a copy of the Media control log:
    2009-11-12 15:53:55:492301" NOTICE:"OpenTransmitter RTP/0 [a] -> G729a:20 PCMU:20 PCMA:20 "
    "2009-11-12 15:53:55:529824" NOTICE:"OpenConnection FXS/4 -> RTP/0 id=70953065889236563"

    "2009-11-12 15:11:19:650584" NOTICE:"OpenTransmitter RTP/0 [a] -> G729a:20 PCMU:20 "
    "2009-11-12 15:11:19:687344" NOTICE:"OpenConnection FXS/4 -> RTP/0 id=70942087952663702"

    Does the fact that RTP ports associated with the remote IP of are in the 10 000 range mean anything? I thought the Epygi used 6000-6099 for RTP. Why would the remote extension be using 10014?

    I have added the remote private subnet to the NAT exclusion table. The VPN "routes" & does not "NAT" between subnets. The remote extension registers to the private IP of the Quadro over the VPN. I can access all devices behind the Quadro over the VPN.

    I am really stuck with this problem any help will be appreciated.

  2. #2
    Quadro Architect
    Join Date
    Jun 2006
    Around myself


    If I understand right, this problem happens only when you from remote extension call to analog handsets, and never happens on calls from remote extension to IP hansdets in the LAN.

    That could mena the problem is in the VPN types. What kind of VPN do you have. For the remote phones to be able to call to analog handsets (with audio), you should have "Remote Subnet <-> Gateway" type connection on the Quadro. For the calls from remote net to the IP Phones, you have to use "Remote Subnet <-> Local Subnet" type connection.

    If you have both types, I assume something happened to the "Remote Subnet <-> Gateway" connection, and thats why the audio is not going through.

    Can you check that?

  3. #3


    Hi davrays there is only 1 tunnel coming up when there should be 2. I am in the process of trying to get the other tunnel up. I have just managed to do that so there are 2 active tunnels: 1) local subnet to remote subnet 2) Quadro to remote subnet
    I had to configure IPSEC credentials for "road warrior" on the firewall at the remote site, as well as the dial out IPSEC VPN. Thanks for the assistance. I will complete the call testing later as the clients are not available yet - TOO EARLY! Cheers Brad

  4. #4


    Hi davrays the remote extension can make calls, however when it is called from office extensions you get the following message: "number dialled temporarily unavailable" what does that mean? I have looked at call control logs & seen that for ext 31 which is the offending remote extension there is an "off hook error", however the customer assures me that the handset is not "off hook". What can cause this? What else should I be looking for? Thanks in advance. Brad

  5. #5


    I have pasted the "Call control log" section I believe is applicable:

    .148 TS: line #18[0](e:31) - OffHookError.
    .149 BeginTone: line #18[0](e:31), tone - TemporaryUnavailable.
    .150 BeginMediaSession: {MG13} - [71232281713075587]<71232281713075587>.
    .150 GetCoinsideInterfaces: {MG0}[] <-> {MG13}[].
    .151 AddPBXCall: line #18, callID - 71232286007380529.
    .151 BeginMediaSession: {MG13} - [71232286007380529]<71232281713075587>.
    .153 RequestMgResource: {MG13}[L:, R:], line #18[0], BuildAlienFxsBridge, media - [<D>, a: PCMU(0), G729(18), telephone-event(101)(fmtp:0-15)], NM:1, NP:1, ND:1, callID - 71232286007380529.
    .154 BeginMediaSession: {MG0} - [71232286007380529]<71232281713075587>.
    .157 RequestMgResource: {MG0}[L:, R:], line #18[0], BuildAlienFxsBridge, media - [<D>, a: PCMU(0), G729(18), telephone-event(101)(fmtp:0-15)], NM:1, NP:1, ND:1, callID - 71232286007380529.
    .166 ProcessMgReply: {MG13}[], line #18, BuildAlienFxsBridge, RTP port - 888, CAC result - OK, media - [<D>, a: PCMU(0), G729(18), telephone-event(101)(fmtp:0-15)], callID - 71232286007380529.
    .173 ReceiveMediaStatistics: there is no CDR yet, MG{0}, sessID - 71232281713075587
    -+- [L0.0.0.0:6018 R0.0.0.0:0] TXP:0, TXC:N/A, TXPS:0, RXP:0, RXC:N/A, RXPS:0, RXL:0, RXJ:0, RXMD:0
    .199 InsertEndpoint: {MG0}<RTP/1003>[] - 71232286007380529.
    .201 ProcessMgReply: {MG0}[], line #18, BuildAlienFxsBridge, RTP port - 6022, CAC result - OK, media - [<D>, a: PCMU(0)(PT:20), G729(18)(PT:20), telephone-event(101)(fmtp:0-15)], callID - 71232286007380529.
    .203 BeginTone: line #18[0](e:31), tone - TemporaryUnavailable.
    .204 CreateFileEndpoint: {MG0}<FILE/1004> - 71232286007380529.
    .206 AcceptAdvFxsN/ACall(None): line #18[0](e:31), callID - 71232281713075587[5403494240519658698], media - [<D>, a: PCMU(0), G729a(18), telephone-event(101)(fmtp:0-15)].
    .213 BeginTone: line #18[0], {MG0}71232286007380529<04000000>(TOS 0xB8), FILE[/telephony/sysmessages/C/tempunavail.wav, PC: 1, a: PCMU(0)] -> RTP[(>>, a: PCMU(0)].
    .214 ToggleSymRtpDetection(On): [(<<].
    .218 BeginTone: line #18[0], {MG13}71232286007380529<04000000>(TOS 0xB8), RTP[>>(, a: PCMU(0)] -> FXS[0].
    .619 OnAdvFxsN/ACallDone(None): line #18[0](e:31), callID - 71232281713075587[5403494240519658698], media - [N/A].
    09:57:25.787 ProcessConnectionClosed(FileOver): {MG0}71232286007380529<0>, line #18[0](e:31).
    .788 TS: line #18[0](e:31) - OffHookWaiting.
    .791 ATS: line #18(e:31) - OnHookSilent.
    .792 TS: line #18[0](e:31) - OnHookSilent.
    .792 CloseAdvFxsN/ACall: line #18[0](e:31), callID - 71232281713075587[5403494240519658698].
    .821 ErasePBXCall: callID - 5403494240519658698.
    .822 ResetFxsBridge: line #18(e:31), sessID - 71232286007380529.
    .823 EndMediaSession: {MG13} - 71232286007380529.
    .840 <<<<<<<<<<<< Handle Map >>>>>>>>>>>>

  6. #6


    Update - I replaced the Snom remote extension with an Atcom 530p I had spare & it is working fine. I will need to check out the Snom "off hook" issue, perhaps the handset is faulty. Thanks Brad

  7. #7
    Quadro Architect
    Join Date
    Jun 2006
    Around myself


    Hi Brad
    so if I understand right, the one-way audio problem is solved now, after fixing the VPN. Is that correct?

    The "Off hook error" most probably is not connected with a faulty handset. For IP Lines Quadro is not actually aware of the state of the handset. So there must be another reason, but I cannot see that from the attached logs. For that the part of log before the ".148 TS: line #18[0](e:31) - OffHookError." line will be needed. And even in that case I am not sure the reason will be clear, as it could be just a side-effect of a problem happened long before. For example, this could be caused by a network problem (up/down), or other issue, making Quadro think that the phone is not ready to answer calls...

    In any case, we could look for the reason (make some expeeriments) only if the problem reapperss, and will be reproducible...

    Best regards,

  8. #8


    Hi David
    Correct the VPN is working correctly! The Atcom handset has replaced the offending Snom 300 handset. I have upgraded the Snom firmware to v7. I tested the Snom at the client today & the "office" cannot call the remote Snom. The error message remains, "OffHookError". I replaced the Snom with the Atcom & calls are working fine & no "OffHookError" message. I did not change the networ, VPN, router, SIP credentials or anything else. I simply swopped two similarly configured handsets. 1 a Snom 300 the other an Atcom530P - The Snom gives the error message, the Atcom works!!!

    I will set the Snom up at my office as a remote extension of my client & run some tests to see if I can replicate the problem. It is really strane because I could call the main office with the Snom, however the main office couldn't call the remote Snom?

    Anyway thanks for the help & will try to resolve the "OffHookError" message.


  9. #9
    Quadro Architect
    Join Date
    Jun 2006
    Around myself


    It must be an incorrect setting on the Snom phone (some of its numerous checkboxes), though I don't know which one exactly

    Factory reset of that phone could help.. You'll need to configure that from scratch then..

  10. #10


    Hi Davrays
    I have just updated my 16x to 5.1.30 as above and now all the 16 standard phones connected will not receive two way audio, all the other phones connected ie local and remote snoms all work fine its just the normal Bt type phones that won't work
    I have tried altering settings (codec, gain control etc ) but no luck

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Remote Extension is not registration
    By almarri in forum Troubleshooting and Problems
    Replies: 11
    Last Post: 06-25-2009, 11:19 AM
  2. Remote Extension
    By HornetSoftIT in forum Troubleshooting and Problems
    Replies: 1
    Last Post: 06-23-2009, 01:29 PM
  3. Remote Extension with no public IP
    By yobtrams in forum 'How Do I' Questions
    Replies: 3
    Last Post: 06-11-2009, 12:42 PM
  4. remote extension
    By dubnik in forum 'How Do I' Questions
    Replies: 5
    Last Post: 04-17-2009, 05:48 AM
  5. IP extension One way Audio
    By ahmad79 in forum Troubleshooting and Problems
    Replies: 2
    Last Post: 09-05-2008, 03:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts