Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Incoming call routing

  1. #1

    Default Incoming call routing

    I'm trying to route incoming SIP calls to a particular extension (15 in my case).
    I specify this in the VoIP Carrier Wizard but when I look in the Extension settings for ext. 99 the 'Attached Line' drop down list says 'None'.
    It works fine for FXO.
    I also need to check that SIP packets from external sources are actually reaching the Quadro. Is there a log somewhere that I'm missing.
    Many thanks in anticipation.

  2. #2

    Default

    The following is an extract from the end of the SIP User Agent log, hope it helps.

    ***************************** SIP message buffer start *****************************
    SIP/2.0 404 Not Found
    Via: SIP/2.0/UDP 77.240.48.141:5061;rport=5061;branch=z9hG4bK7b0590 ec
    To: <sip:08455570074@81.137.181.205>;tag=12577828608c6 a9263-4f14-4436-9fd1-a59d8534e34b
    From: "07929349816" <sip:07929349816@77.240.48.141:5061>;tag=as501b629 c
    CSeq: 102 INVITE
    Call-ID: 16378b4d7a3157702aa39f5370d680f2@77.240.48.141
    Server: Epygi Quadro SIP User Agent/v5.0.12 (QUADRO-4X/16X)
    Content-Length: 0

    ***************************** SIP message buffer end ******************************

    08:29:09 Receive SIP message # (10/11/2009 08:29:09:594 GMT) # UDP # 456 bytes # buff size 1 # from: 77.240.48.141:5061 # to: 81.137.181.205:5060

    ***************************** SIP message buffer start *****************************
    ACK sip:08455570074@81.137.181.205 SIP/2.0
    Via: SIP/2.0/UDP 77.240.48.141:5061;branch=z9hG4bK7b0590ec;rport
    From: "07929349816" <sip:07929349816@77.240.48.141:5061>;tag=as501b629 c
    To: <sip:08455570074@81.137.181.205>;tag=12577828608c6 a9263-4f14-4436-9fd1-a59d8534e34b
    Contact: <sip:07929349816@77.240.48.141:5061>
    Call-ID: 16378b4d7a3157702aa39f5370d680f2@77.240.48.141
    CSeq: 102 ACK
    User-Agent: Asterisk PBX
    Max-Forwards: 70
    Content-Length: 0

    ***************************** SIP message buffer end ******************************

  3. #3
    Quadro Architect
    Join Date
    Jun 2006
    Location
    Around myself
    Posts
    2,075

    Default

    I suppose you specified ext 15 as the destination for incoming calls. In that case system automatically configure an Unconditional Forwarding from ext 99 to ext 15. You can see that in the ext 99 forwarding settings. So no need to worry - your ext 99 should not be attached to any line, as the calls are finally directed to ext 15.

    Now - what is the real problem? You call to your account number and this call is rejected with "Not Found" message? From the log I can see that the call comes to Quadro with "08455570074" as the destination number. Is that the account number you configured, or that is just a DID?

  4. #4

    Default Did

    No. This is a number allocated to me by by SIP trunk provider.
    I've spoken to them and they say that the 'Content Length = 0' in the log indicates no SDP information in the packets.
    They are looking into this.
    I'm wondering if their Asterisk PBX has an issue with the Quadro?
    Thanks for the response.

  5. #5

    Default 08455570074

    Sorry - The above is not the account number that I use to authenticate to the SIP trunk, I have an account number+password for this. The Quadro appears to register OK.

  6. #6

    Default

    hmmm... when i connect the Quadro's to an Asterisk based service, I have to go to a hidden page and click "Accept stray SIP requests" ..

    This results in the call going to where it should and ignoring the registration for incoming calls. Outbound calls via an Asterisk system are usually not a problem for the Quadro its just the incoming request that causes the problem. I believe David will tell you the right way to overcome this.

    In my case :
    Asterisk seems to send from a different sip server address to that of the Voip line that is configured.


    Ie, you follow the Voip wizard, the outgoing Voip carrier in most circumstances is a single ip address, but in my case the Voip carrier is sending from a seperate ip address than it is receiving on...

    Make sense...

    The above = a call outbound no problem, a call inbound = refused due to the call routing for sip

    I deal in a business wan environment and because the Voip carrier is not internet based I have very few issues.

    <insert davids words of wisdom after here>

    Kevin

  7. #7

    Default

    Thanks. This appears to be what is happening but I don't know how to get to the hidden page.
    Also, where is the setting that does the unconditional forwarding from 99 to 15. I can't find this anywhere.

  8. #8
    Quadro Architect
    Join Date
    Jun 2006
    Location
    Around myself
    Posts
    2,075

    Default

    Peter, first of all, we need to understand what this number is (08455570074) - can you find that out? And also I need to know whether you have an extension with that number set as a username. If you don't have that, just create it, and the calls will come to that extension. Then you can forward them to any destination you need.

    In any case I'll try to answer your questions (though I am not sure this information is really what you need):
    1. "Content-Length: 0" has most probably no relateion to the problem. The SDP should not be present in the SIP messages you posted above, so those messages are absolutely correct.

    2. To find the forwarding settings, you will need to open "Users"->"Extension Management", click on "99" in the table, then open the "Caller ID based Services" from the menu. Look for "Unconditional Forwarding" there.

    3. The "Accept SIP stray requests" checkbox in on the "generalconfig.cgi" hidden page. You can call that page by typing "http://<QuadroIPaddress>/generalconfig.cgi".

    But first of all, we need answers to the questions in the beginning of this post.

  9. #9

    Default 08455570074

    If you want to call me through the Epygi this is the number uou would use (assuming you are in the UK), e.g. it is the phone number of the PBX. I only have and want one number.
    My scenario is to route all calls made on that number to a single extension, 15 attached to IP Line 1. I am trying to do this by routing all incoming calls (IP and FXO) to extension 15. It's easy for FXO!
    I don't have an extension with this number.
    I have checked the Caller ID Based Services and it looks OK. The Forward To column says PBX-15.

  10. #10
    Quadro Architect
    Join Date
    Jun 2006
    Location
    Around myself
    Posts
    2,075

    Default

    Ok, so the easiest solution for your problem is to set the SIP username of the ext.15 to "08455570074" (also uncheck the "Register on SIP server" checkbox).

    Try that - it should route all your incoming calls from ITSP to ext 15...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Routing incoming SIP call - Dual E1 ports gateway
    By waik in forum 'How Do I' Questions
    Replies: 2
    Last Post: 07-07-2009, 06:56 PM
  2. Incoming call routing not working...
    By excellence-it in forum General Discussions
    Replies: 5
    Last Post: 03-10-2008, 03:20 AM
  3. Incoming routing rules
    By mjnorris in forum 'How Do I' Questions
    Replies: 1
    Last Post: 01-30-2008, 03:23 AM
  4. Call routing based on incoming DID
    By wesleyit in forum 'How Do I' Questions
    Replies: 3
    Last Post: 12-03-2006, 02:15 PM
  5. Routing Incoming PSTN calls to VOIP
    By mskinner in forum 'How Do I' Questions
    Replies: 4
    Last Post: 08-25-2006, 09:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •