Results 1 to 8 of 8

Thread: one way audio between Aastra 57iCT & Snom 360

  1. #1

    Default one way audio between Aastra 57iCT & Snom 360

    Hi All,

    I am looking for some advice for a problem we are experiencing on our system.

    We have quadro 4x4 with a mix of snom 3xx handsets and 2 Aastra 57iCT's.

    Quadro is running 5.1.18 firmware
    Snoms are running 7.3.4
    Aastras are running 2.5.1.41

    Since upgrading the system to 5.1.18 we have been having issues with audio on calls between Snom 360 (all other snoms are fine) and Aastra 57iCT.

    When a call is made from the Aastra to the snom 360 we get no audio coming from the Snom. Audio from Aastra to snom is fine.
    Calls in the opposite direction are fine eg from Snom to Aastra.

    The network is a flat subnet with no vlans or NAT.

    The problem has been replicated with another separate Aastra handset which is working as a remote extension at another office.

    If a call is made from the Aastra to any other extension and then transferred to the Snom 360 the audio is fine. It only seems to be when call is initially terminated onto the Snom 360 that this occurs.

    Codecs are all locked to G729a on the Epygi.


    I have attached a text file showing SIP trace on the epygi.

    Ext 30 is the Aastra
    Ext 20 is the Snom 360

    The first call is from Ext 30 to Ext 20 (problem audio)
    The second call is from Ext 20 to Ext 30 (normal call)

    I am at a loss as to where to go from here so any assistance would be appreciated.

    Regards
    Scott
    Attached Files Attached Files

  2. #2
    Quadro Architect
    Join Date
    Jun 2006
    Location
    Around myself
    Posts
    2,075

    Default

    Where is the second call log, Scott ? You attached only the failed call log.

    The log seems to be pretty good (and shows that Quadro has nothing to do with this problkem, as the audio goes directly between Aastra and Snom), except one thing, which I don't really like in that log:

    in the BYE message from Snom you can see

    **********************************************
    BYE sip:30@187.226.0.51:5060 SIP/2.0
    Via: SIP/2.0/UDP 187.226.0.200:2051;branch=z9hG4bK-yvybgtalymyv;rport
    From: <sip:locext20@187.226.0.51:5060>;tag=s5rkcc19kv
    To: "House 1" <sip:30@187.226.0.51>;tag=1245192576869bf9db-17d9-4495-a21b-e8ae00a1fa89
    Call-ID: 18386042029682635_d9d9ef0a-95d1-4c70...bx.esscom.local
    CSeq: 1 BYE
    Max-Forwards: 70
    Contact: <sip:locext20@187.226.0.200:2051>;reg-id=1
    User-Agent: snom360/7.3.4
    RTP-RxStat: Total_Rx_Pkts=574,Rx_Pkts=574,Rx_Pkts_Lost=0,Remot e_Rx_Pkts_Lost=0
    RTP-TxStat: Total_Tx_Pkts=0,Tx_Pkts=0,Remote_Tx_Pkts=1284

    Content-Length: 0
    **********************************************

    I don't know exactly what does the "Remote_Tx_Pkts" mean in te Snom's message (this is their proprietary thing, as far as I know), but "Total_Tx_Pkts=0,Tx_Pkts=0" should mean that Snom is not sending packets at all.

    Why it is not sending them - that is a question to Snom.
    I can only make guesses:

    Guess #1: this Snom fw (7.3.4) is not the version recommended to use with Quadro 5.1... It *might* be that upgrading to latest recommended Snom fw could help. Probability is small, but anyway you can try...

    Guess #2: I suspect that the problem is connected with packetization time suggested by Aastra ("a=ptime:30" in INVITE). It might be that Snom is not handling well the 30 msec packetization interval suggested by Aastra. The probability that this is the reason, is not so small here...

    Try to change the packetization interval/time on all phones (especially on Aastra) to 20 msec (using phones own GUI). This is the de-facto standard, and should be OK with both phones. See if that clears the problem..

    Best regards,
    David

  3. #3

    Default

    G'day David,

    Thanks for the suggestions, i tried what you suggested with the 20ms packetisation interval but this did not seem to make any difference. I don't have access to the Aastra in question today so cannot get any further logs but i will attempt to provide successful call logs at a later date.

    In the mean time i will chase up snom to see if there are any known issues.

    Regards
    Scott

  4. #4
    Senior Member
    Join Date
    Mar 2008
    Location
    South Africa
    Posts
    110

    Default

    Hi Scott,

    Had similar issue on the Epygi M32x with latest firmware, ended up being a codec problem, i normally enabled "force prefered codec on inbound call", on all my installs, for every extension. If you have this enabled, disable it, on both extensions....the snom and aastra....and see if this helps.

    regards,

    shaun

  5. #5
    Quadro Architect
    Join Date
    Jun 2006
    Location
    Around myself
    Posts
    2,075

    Default

    Guys, even if you are able to solve (or better to say workaround this problem) by changing settings on Quadro, this is definitely Snom-related problem.

    BTW, Scott, how did you try the 20 msec solution, if you don't have access to the Aastra in question? You should have set the 20 msec packetization interval on Aastra...

  6. #6
    Senior Member
    Join Date
    Mar 2008
    Location
    South Africa
    Posts
    110

    Default

    But David,

    When this problem happened, i tried downgrading the snom and Aastra to the previous firmware's. I went through about five older snom firmware's before looking to the Epygi settings, the problem was only resolved once i changed the codec settings under both extensions.

    regards,

    Shaun

  7. #7
    Quadro Architect
    Join Date
    Jun 2006
    Location
    Around myself
    Posts
    2,075

    Default

    Changes on the Quadro may help to workaround the problem (for example, to alternate original SIP messages between Aastra and Snom), but the problem is in the phones, as the audio is directy passing between Snom and Aastra. Quadro has nothing to do there, and it cannot be responsible for Snom not sending the packets out...

    Best regards,
    David

  8. #8

    Default

    Hi All,

    Sorry for the delayed response i have been out of the office for several weeks.

    I managed to get access to the aastra and tried changing the packetisation delay. This did not help.

    After trying many different configurations i narrowed it down to the Snom Firmware as being the cause of this problem.

    I believe it was 7.3.14 that seemed to have a problem with negotiating the G.729 codec on an incoming call from an Aastra.

    I upgraded and downgraded a number of times to prove this and in each case 7.3.14 did not work.

    7.3.24 is currently working fine with G.729 in all instances.

    Thankyou all for you time and suggestions.

    Regards
    Scott

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 12-13-2008, 05:47 AM
  2. Remote 57iCT with 4.1.52
    By Synertic in forum Hardware Interoperability
    Replies: 0
    Last Post: 04-08-2008, 09:55 AM
  3. Getting Aastra 57iCT to Authenticate with Quadro2x
    By ozbeanz in forum Troubleshooting and Problems
    Replies: 3
    Last Post: 01-29-2008, 02:04 AM
  4. one way audio though SIP
    By TFIDemo in forum Troubleshooting and Problems
    Replies: 6
    Last Post: 01-25-2008, 01:39 AM
  5. QCM audio
    By maribelronquillo in forum Troubleshooting and Problems
    Replies: 6
    Last Post: 06-22-2006, 06:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •