Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Remote Ip phone

  1. #1

    Default Remote Ip phone

    Hi,

    I have a Quadro 16X firmware 5.0.19 behind a firewall fortigate brand Fortinet in a "office A" with a static IP public address. Also i have in other place another Firewall Fortigate and a IP phone Grandstream GXP 2000 firmware 1.1.6.16 in a "Office B" with a dynamic ISP. The point is to connect this Ip phone to the Quadro like if it were in the "office A" using remote extention.

    What I did is a VPN dialup in the Fortigate`s, the VPN work!, then i use the manual "Quadro Remote Extension Configuration" from epygi to config the IP phone, I did the following: using in the Sip server and the Outbound Proxy: <WAN IP address of the Quadro>:5060. In SIP User ID and Authenticate ID: <the user name the i config on remote extension on the Quadro for that extension>, the password is the same that i use on remote extension on the Quadro. The Ip phone registered, when i try to call to an internal extention, the people answer, i hear them BUT THEY DONT HEAR ME. That is my problem.

    I disable the sip-helper on my firewall, all the ports are open for this VPN, and no filter is apply to the firewall policy of the VPN dialup.

    What ca i do??? i really appreciated your help

  2. #2

    Default

    Quote Originally Posted by AB View Post
    Hi,

    I have a Quadro 16X firmware 5.0.19 behind a firewall fortigate brand Fortinet in a "office A" with a static IP public address. Also i have in other place another Firewall Fortigate and a IP phone Grandstream GXP 2000 firmware 1.1.6.16 in a "Office B" with a dynamic ISP. The point is to connect this Ip phone to the Quadro like if it were in the "office A" using remote extention.

    What I did is a VPN dialup in the Fortigate`s, the VPN work!, then i use the manual "Quadro Remote Extension Configuration" from epygi to config the IP phone, I did the following: using in the Sip server and the Outbound Proxy: <WAN IP address of the Quadro>:5060. In SIP User ID and Authenticate ID: <the user name the i config on remote extension on the Quadro for that extension>, the password is the same that i use on remote extension on the Quadro. The Ip phone registered, when i try to call to an internal extention, the people answer, i hear them BUT THEY DONT HEAR ME. That is my problem.

    I disable the sip-helper on my firewall, all the ports are open for this VPN, and no filter is apply to the firewall policy of the VPN dialup.

    What ca i do??? i really appreciated your help

    From the sounds of it you need to rectify the NAT issue - 1 way communication happens due to NATting problems. I have heard that if you point your phone to use the settings of the VPN as its gateway rather than the router settings that might remedy your problem...

    When you tie to Quadros together via a VPN you dont use the physical ip address of the routers you use the VPN ips and it then works correctly.

    So doing this at the phone level should also work.

    Regards

    Kev

  3. #3
    Quadro Architect
    Join Date
    Jun 2006
    Location
    Around myself
    Posts
    2,075

    Default

    AB, from what you have explained I suspect the following:

    if the VPN subnets are different for the local and remote offices, and the "NAT Traversal" is enabled on the Quadro, Quadro will most probably send the NAT-ed addresses to the phone, thus the phone will send the audio to wrong place.

    Try to add your phone's VPN subnet to the "NAT Exclusion Table" on the Quadro. If this doesn't help, try to disable the NAT traversal at all on the Quadro (Telephony->NAT Traversal Settings), just for experiment - to see if it helps (note that you may need to use the NAT Traversal for external calls, so the "NAT Exclusion Table" approach is preferred)...

    Best regards,
    David

  4. #4

    Default

    Hi,
    The NAT exclusion table was the solution!!! THANK YOU SO MUCH

  5. #5
    Quadro Architect
    Join Date
    Jun 2006
    Location
    Around myself
    Posts
    2,075

    Default

    You're welcome

    The "NAT Exclusion Table" is a bit underrated (not very famous) page, but in practice it always needs to be used when Quadro is installed in a network having multiple subnets, with phones in different subnets, regardless of whether they are connected via VPN or via regular router...

    Best regards,
    David

  6. #6

    Talking the best advice ever!

    Hi David & Kevin
    I have been toiling long & hard for the past 12 months with VPN's & Quadro remote extensions. The Draytek voip routers do VPN extensions easily but not Epygi! Well that is only if you don't know what to do! Your advice to add the remote subnet to the NAT exclusion table has worked a treat! Thanks a million i just tried it & audio is working perfectly for extension o extension calls as well as SIP calls & ITSP calls. The forum gets better & better. Now to master the audio streaming! Cheers Brad

  7. #7

    Default

    Quote Originally Posted by davrays View Post
    You're welcome

    The "NAT Exclusion Table" is a bit underrated (not very famous) page, but in practice it always needs to be used when Quadro is installed in a network having multiple subnets, with phones in different subnets, regardless of whether they are connected via VPN or via regular router...

    Best regards,
    David
    This took me weeks of head banging before I discover it perhaps there should be some bold note in the manual with reference to adding the relevant subnet to this table if you deploy internally via VPN and private subnet.

  8. #8

    Default

    Quote Originally Posted by woods View Post
    This took me weeks of head banging before I discover it perhaps there should be some bold note in the manual with reference to adding the relevant subnet to this table if you deploy internally via VPN and private subnet.
    Agreed Ben,

    I think it would be great to have an area for setups and how to's stickied here in the forum so when something is found to work for a given situation it is easily found rather than trawling the forum and doing advanced searches or waiting for someone in the know to reply ...

    BTW .... it was Ben ( another ozzie go figure ) that was able to dig this one out and rectify the situation for his own deployment.

    Cheers...

    Kev

  9. #9

    Default

    Hi,

    I found this thread after also having the same problem.

    At the moment, everything is working for me, however, in the call details there are no stats showing for calls made from the remote subnet. I would like to see the stats so I can see how call quality is going.

    I couldn't get Nat Exclusion Table to make any difference, but when turning off Nat Traversal completely everything started to work fine.

    I've been chatting quite alot with Alloy, who have been helpful, but this has stumped them so far.

    As a quick summary:

    Main office. Draytek 3200. Epygi 2x on hardware DMZ port. Office phones on subnet 192.168.1.0 and all is fine.

    Remote office. Also has a Draytek 3200 and it has a PPTP VPN into main office Draytek. Subnet is 192.168.5.0

    To get everything working for me, I had to disable Remote Extension setting - so the "remote" office is acting as a "real" extension. After doing this, almost everything worked. That is, incoming PSTN calls could be answered by remote office (voice working both directions). Calls between offices (between extensions) also work fine. However, when calls made from/to DID's (Engin VSP) only audio could be heard in 1 direction.

    When I found this thread, I then tried the Nat Exclusion Table, but it made no difference. So, I disable Nat Traversal completely, then everything is solved. All is working for all call types.

    So, (as above) I just can't see call statistics for the remote office.

    Any hints on how to get this going would be appreciated.

    Thanks.

  10. #10
    Quadro Architect
    Join Date
    Jun 2006
    Location
    Around myself
    Posts
    2,075

    Default

    Typically the RTP details (packet stats and quality rating) are not shown in cases when RTP streams do not pass through Quadro. If stream goes directly from phone to ITSP, the PBX has no information about the stream quality, and so cannot show the quality stats.

    To force stream to go through PBX (so you have stats), you have to activate RTP proxy on the ITSP routing rule. But note that in this case the overall traffic through your VPN will strongly increase, as the voice streams have to go from remote phone to Quadro, then from Quadro to ITSP. I suppose it is better to stay without those stats, than to increase the traffic unnecessarily.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Remote phone(easiest to config)
    By serviplexSIP in forum 'How Do I' Questions
    Replies: 9
    Last Post: 06-09-2009, 05:29 AM
  2. Get two remote extensions operating at one remote location
    By sjet701 in forum 'How Do I' Questions
    Replies: 5
    Last Post: 08-26-2008, 09:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •