Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Making calls with +00xx prefix with Quadro4xi and Snoms phones

  1. #1

    Default Making calls with +00xx prefix with Quadro4xi and Snoms phones

    Hi everyone,

    We have problems when making calls with a Quadro4xi using the + in the prefix number, it's not working.

    We can make calls without the + without problem, like 0041 for exemple.

    Any workaround?

    We also have problems when we want to divert calls using *21*number#, our phones doesn't make the right redirection but instead it calls the last number called.

    Thanks in advance if any of you have solutions.

    (it's the same problems with all of our snom phones, Snom300, 370, M3)

    Swenz
    Last edited by swenz; 09-23-2008 at 03:28 AM.

  2. #2
    Quadro Architect
    Join Date
    Jun 2006
    Location
    Around myself
    Posts
    2,075

    Default

    Hello Swenz,

    Quote Originally Posted by swenz View Post
    We have problems when making calls with a Quadro4xi using the + in the prefix number, it's not working.
    We can make calls without the + without problem, like 0041 for exemple.
    Any workaround?
    Quadro adds '+' sign as a prefix for the SIP/IPPSTN calls without problems (I tested that on my device running 5.0 SW). You can see that frrom the SIP logs on the Quadro, for example - the '+' sign should be in the request line of the INVITE message. Most probably your ITSP does not accept calls prefixed with '+'.

    Quote Originally Posted by swenz View Post
    We also have problems when we want to divert calls using *21*number#, our phones doesn't make the right redirection but instead it calls the last number called.
    Why do you think calls should be diverted using *21*number# on Quadro? Probably that is the code on your telco, but there are many other telcos and the codes used are different...
    On Quadro you can use *4 instead, and follow voice prompts.
    The last number is blocked, because the '*2' is the code for blocking the last number

  3. #3

    Default

    A small mistake, David. *2 is not the code for blocking the last caller, but the code for callback to last caller.

    Swenz, in your case when you're dialing *21*number#, the string is not getting passed to the PSTN, as you expecting, but to the Quadro. The first two dialled digits (*2) are getting matched to the Quadro dialplan and you've get a callback function. If you want to use your Telco *21*number# code for configuring fowarding, then you must get a Telco dialtone first and inject forwarding code to Telco directly, or do that by creating and using special Call Routing rule on Quadro. However, I will not recommend you to use Telco forwarding future, but the Quadro forwarding future instead, which can be activated by *4, correctly suggested by David.

  4. #4
    Quadro Architect
    Join Date
    Jun 2006
    Location
    Around myself
    Posts
    2,075

    Default

    Quote Originally Posted by aramk View Post
    A small mistake, David. *2 is not the code for blocking the last caller, but the code for callback to last caller.
    Ehh... I have to make mistakes sometimes .. to make you speak a little, Aram

    Quote Originally Posted by aramk View Post
    Swenz, in your case when you're dialing *21*number#, the string is not getting passed to the PSTN, as you expecting, but to the Quadro. The first two dialled digits (*2) are getting matched to the Quadro dialplan and you've get a callback function. If you want to use your Telco *21*number# code for configuring fowarding, then you must get a Telco dialtone first and inject forwarding code to Telco directly, or do that by creating and using special Call Routing rule on Quadro.
    That can be a rule with pattern "9\*21\**", NDS=1, suffix=#, calltype=FXO.
    So you can directly dial 9*21*number#, and the necessary "*21*number#" combination will be injected to telco. You have to create this specific rule to be ablet to sendd the last "#" to telco, otherwise the standard "9?*" rule would have been enough.
    All this is true only if you really want to activate the forwarding service of telco, of course

  5. #5

    Talking Old, good habits :)

    It is a bit strange, but I still clearly remember Quadro calling codes

  6. #6
    Quadro Architect
    Join Date
    Jun 2006
    Location
    Around myself
    Posts
    2,075

    Default

    Probably they are recorded on the back side of your brain, Aram, on the honorary memorial tablet. And you probably still automatically try to login to everything using Quadro login/password first, like we all do here... ?

    P.S. You can answer me via PM, if you want I don't think that Swenz is very interested in our flooding here

  7. #7

    Default

    Hi,

    Thank you for all the replies.

    We're using ISDN (Switzerland) instead of FXO and we get this error on the Quadro :

    24-Sep-2008 09:08:37 "11" 11 PSTN?-*21*0797762061# "Network Failure"
    ISDN : Invalid number format ( address incomplete )

    Any idea how we can bypass the Quadro correctly to use the call forwarding solution of our telco instead?

    We don't want to use the Quadro's solution for forwarding because when redirecting calls this way the person who receive the redirected calls can only see the phone number of the Quadro.

    Thanks in advance,

    Swenz
    Last edited by swenz; 09-24-2008 at 05:40 AM.

  8. #8

    Default

    Hi Swenz , I found a document that might point to a problem in your call routing. http://www.swisscom-fixnet.ch/FxRes/...s_28052004.pdf

    It stated that a *21 telephone number then # is needed to be transmitted and other derivitives.

    10-3 is where it states all of this... Table 10-1 page 73

    I hope that helps and it might explain the problems you are receiving.

    Regards

    Kevin

  9. #9

    Default

    Quote Originally Posted by KSComs View Post

    It stated that a *21 telephone number then # is needed to be transmitted and other derivitives.
    Hello,

    Thanks for trying to help.

    Yes, *21*number# is Swisscom (Swiss telco) procedure for call forwarding.

    The problem reside with our Quadro, we can't understand how we can configure it to make call forwarding properly without using Quadro's function but our telco forwarding function.

    Thanks.

    Swenz

  10. #10

    Default

    Hi Swenz, what about the following method...

    In the call routing tables put the following :

    Pattern 222 , NDS 3 , suffix *21telephonenumber# , Call Type ISDN

    Move it to a high position in your call routes. From any phone simply dial 222 and that will set up the call forwarding.

    To disable use the following

    Pattern 333 , NDS 3 , suffix #21# , Call Tpye ISDN

    Move it to a high position in your call routes.


    Regards

    Kevin

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Making large (>25 participants)conference
    By pchojnow in forum 'How Do I' Questions
    Replies: 5
    Last Post: 04-23-2009, 04:48 AM
  2. Recording Calls Using Snom IP phones
    By lansmart in forum Suggestions and Feedback
    Replies: 6
    Last Post: 07-08-2008, 02:29 PM
  3. phones
    By bsnquadro in forum Hardware Interoperability
    Replies: 3
    Last Post: 02-26-2008, 02:39 AM
  4. Prefix Tag on call Routing
    By nlucas in forum 'How Do I' Questions
    Replies: 2
    Last Post: 06-27-2007, 10:09 PM
  5. Include the prefix "0" to recall (2)
    By support.ephonenet in forum 'How Do I' Questions
    Replies: 1
    Last Post: 11-06-2006, 07:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •