What are our options for older hardware systems 4x and 2x that can't be upgraded to 5.2 software. I would like to enable IDS for SIP attacks but think I have to upgrade to 5.2 but the upgrade fails.