PDA

View Full Version : 'IP Connection Cannot Be Established'



yellowgrid
07-19-2008, 04:18 PM
We've been living with this for some time. We have tried all sorts to resolve it.

Often (Most times) when we attempt to make a call we are presented with the following audio 'IP Connection Cannot Be Established'. 9 times out of 10 if we replace the handset and make the call again it connects.

The logs look like this:

.017 OnSIPCallReportError: line #2[0](e:14), got error code "Incorrect Target", callID - 36656244496821211.
.020 KillTimer: line #2, type - FaintHopeHypnosis, callID - 36656244496821211.
.021 EndTone: line #2(e:14), tone - None.
.022 OnErrorMoveNext: line #2[0](e:14), got error "Incorrect Target", end of call records.
.022 EndMediaSession(*): {MG0} - 36656244496821211.
.023 EraseEndpoint: {MG0}<RTP/1001>[172.40.0.1:6026] - 36656244496821211.
.024 EraseEndpoint: {MG0}<RTP/1002>[x.x.x.x:6028] - 36656244496821211.
.024 EndMediaSession: {MG0} - 36656244496821211, ownerID - 36656244496821211, requesting RTP statistics.
.026 EndMediaSession: RESET {MG0}.
.026 EndMediaSession(*): {MG5} - 36656244496821211.
.027 EraseEndpoint: {MG5}<RTP/1001>[172.40.255.252:49662] - 36656244496821211.
.029 EndMediaSession: RESET {MG5}.
.032 <<<<<<<<<<<< Handle Map >>>>>>>>>>>>
C:
#2 , ID - 36656244496821211.->SIP
#2 , ID - 5224803015227537537.->PBX


What I don't understand is what 172.40.255.252 address has to do with anything. Its not an IP address assigned to the Epygi

Any ideas?

Thanks

Craig

davrays
07-23-2008, 10:28 AM
Hello Craig

the 172.40.255.252 is the IP address of the IP Phone, with tried to call out.
The piece of logs you posted is not enough to tell the exact reason of getting such "Incorrect Target" message. Typically this happens when a problem with DNS server exists (it does not resolve the destination hostname).. Also ICMP Destination Unreachable message could be a reason for this. You can look for the reason in the SIP UA logs - it looks like it didn't receive the expected answer to the INVITE message sent.

Best regards,
David