PDA

View Full Version : Problem connecting to external Asterisk box



malcolmct
06-25-2008, 10:15 AM
I'm having a problem connecting my Quadro 2X to an Asterisk server which I maintain on the internet. The Quadro is directly attached to a cable modem and is used as the sole router on my network.

I used the VOIP carrier wizard to set up the link and it registers successfully, allowing incoming calls from the Asterisk box to the Quadro. However, I cannot make calls from the Quadro to the Asterisk server - getting the message "Access to this number blocked".

From what I can see in the logs (and I'm no expert), the problem is due to a 407 Proxy Authentication Required at the Asterisk end, but I'm sure that it is caused by some misconfiguration of the Quadro.

I'd be really grateful if somebody could take a look at the attached log of a call from my LAN phone to the Asterisk server and offer some advice (I've replaced IP addresses and DNS names with labels in square brackets to protect the innocent!)

Many thanks,

Malcolm

davrays
06-26-2008, 09:55 AM
I looked through the log, and I don't see anything suspisious there. It looks like username/password are wrong. But the question is: how the registration passed with wrong password?
May it be that the registration on asterisk is set to be done without authorozation?

malcolmct
06-26-2008, 12:03 PM
Thanks davrays - the Asterisk box definitely needs authorization to register. I'll try to debug further and will report back if I get anywhere.

malcolmct
06-29-2008, 10:01 AM
As a test, I removed the password from my account on the Asterisk side and everything worked perfectly. I then locked the Asterisk extension into the internet host address of my Quadro box to prevent abuse.

It's not an ideal solution, but it does work. I'm going to upgrade to the v5.0 firmware as soon as it ships, so I won't be spending any more time trying to debug this one.