PDA

View Full Version : SMS recipient Germany cuts leading 0



mountrcg
03-15-2008, 07:14 AM
The SMS Recipient Address fields in the different forms on Epygi 2x, like in SMS Settings form or Voice Mail Settings only accepts numbers, which is fine.
Unfortunatly it cuts off leading "0"s, so that I am not able to send SMS via clickatel. Any hints, bug or feature.
Here my specs:
Quadro Operating system: 4.1.52 root@Delta.epygi.loc Application Software: 4.1.52 - Release Boot Loader: PPCBoot 3.1.18/Release DSP Software: Version: 4.1.36.Date: Dec 27 2007 9:45

AramK
03-17-2008, 02:03 AM
Thanks for finding this out, this is bug in Quadro that will be fixed in future SW releases.

AramK
03-25-2008, 02:21 AM
It seems that the problem described here is not connected to the Quadro, but rather to the wrong phone number format used by mountrcg. There is no need for using leading 0s in the recepients address.
Here is the quote of newest Clickatell's HTTP API document:

"Destination Address - the number of the handset to which the message must be delivered. The number should be in international number format. No "00" prefix or
leading "+" symbol should be used."

Anyway, we will allow just one leading "0" just in case if it will be needed in some countries, but I doubt there are an international number containing leading 0.

mountrcg
03-25-2008, 10:29 AM
I need exactly one leading 0 to send an SMS to a mobile handset in Germany.

From clickatels webpage http://support.clickatell.com/guides/clickatell/api_guide.php
"Dial Prefix:
If a lot of local numbers are sent with this API which start with a zero, you can specify the default country prefix to replace the leading zero. Ie: if you are sending primarily to the UK, you can specify that the default prefix is 44. This will change the leading zero (if present) to 44."

So a leading 0 needs to be sent.

AramK
03-26-2008, 01:40 AM
OK, we already fixed this in SW 5.0.x. It will be possible to add one leading 0 to the SMS Recipient Address.