PDA

View Full Version : What is the best setting for the echo can



Synertic
07-10-2007, 09:24 AM
I always have a probleme with the echo on fxo line. Someday i don't earmy clients on the line , someday my client don't ear me

My settin is:<
DSP Echo Cancelation
Echo Tail 64
Echo NLP Diff 25
Echo NLP Shift 2
i have installed the new version 4.1.29 and the probleme is here again.

Ho the Caller ID is don't work on the FXO line







Edited by: Sparxnet

woosha
07-10-2007, 10:48 AM
I too am having a number of customers complaining of echo's on FXO calls. I have tried playing with the echo tail settings as mentioned above and in other threads. Are there any other settings which affect this? It only seems to happen with FXO calls, VoIP calls are fine.

I've also got a couple of customers complaining of 'noise' on their FXO calls, are there any settings to reduce static? Or is this more a case of poor quality components used for the FXO ports?

Edit: To the poster above, the reason you're getting no caller id through the FXO port(s) is likely because your landline provider hasn't enabled it on their line.

Edited by: woosha

Synertic
07-24-2007, 06:50 AM
Great thanks to Epygi technical support for help me to sell great products to my custumer..............

Stebo
07-24-2007, 05:58 PM
I have the same problem! Never fixed from Epygi technical support!

souren
07-24-2007, 07:22 PM
Echo problem is solved per case because it is related to Central Office(CO) parameters and even can go beyond your CO. Depending on the call path behind CO, parameters such as delay for instance can vary. You may not have echo for local calls but may have it for long distance calls etc. Also Echo Return Level param may vary, which is representing how loud the echo is returning. So there is no settings for all of the cases. I would recommend to submit cases with dspcaptures when you can't eliminate echo yourself. You may take the channel numbers for the capture from "FXS/FXO/ISDN Diagnostics Guide" document located in Download section. Make sure you are capturing the call that is containing the echo.
In most of the cases echo listeners are IP Phones, since they have better voice amplification than analog phones, thus the echo is more noticable on them. Sometimes we would also need network capture from Quadro to IP phone. If you will prepare all that information along with Quadro system logs in the TSS ticket, we can quickly sort out the proper values for your CO and solve the echo issue.

For VoIP calls the source of echo is located on VoIP service provider side or behind it. Usually they are setting up robust equipment to cancel the echo. In this call path Quadro is just receiving the RTP stream and passing to phone. Quadro is not doing any echo cancellation since it is done on other end.

Some of the CO's in Canada has unique Caller ID implementation of FSK signal and we had implemented workaround for it. This workaround was postponed from implementing in 4.1.29, but it is already implemented in further versions. So in next public release you will have it.

Hope it helps,
Souren

souren
07-24-2007, 07:23 PM
Stebo

Could you please open a new ticket, refering to the case number, where it wasn't solved?

Thanks,
Souren