View Full Version : On hold music

03-15-2007, 01:31 PM
Is there a bug in the firmware:

If "Send Hold Music to remote IP party" is checked, once a call is put on hold,the callerhears the on hold music, but to bring the caller back off hold, no voice can be heard by either party.

Without disconnecting the call, I can uncheck the "Send Hold Music to remote IP party" and put on hold and off hold and I can hear the caller again.

Firmware I have is 4.1.18. But my office manager mentioned that this started happening 1 week ago, before I even upgraded to 4.1.18.

Is there any known resolution to this problem?

03-16-2007, 10:18 AM
Is this all calls, or just calls through an ITSP?
We experienced the same thing, and the ITSP we are using tracked the issue to the configuration of their Session Border Controller.

The ITSP wasn't reacting to the SIP INVITE messages when the call was taken off hold etc, but doing the HOLD cycle a second time helped the ITSP "catch up" with the RTP stream.

Find out if your ITSP is running a Broadsoft system.

03-20-2007, 08:46 AM
We use Broadvoice as the ITSP. It use to work then it just stopped. Putting the call on hold twice has not helped.

What should we ask the ITSP to check for them to be able to fix it?

They do use a Broadsoft system...

And it does only happen on theextension that the VOIP is forwarding to.Edited by: etolentino

03-20-2007, 02:17 PM
Got a hold of a technician that analyzed the sip session and nothing is coming up that is noticeable to him.

How is it the ITSP's issue when I can reproduce the issue mid-call, and take the feature off and bring the caller back?

So whenever the hold music is enabled, I am not able to hear the other party coming back from hold.

04-11-2007, 11:27 PM
Such an issue existed in 4x/16x 4.0.7 version only: there was a real bug, and it is better not to check "Send Hold Music to remote IP party" on that version.

But in further images this issue is fixed. So it seems you have to refer to Epygi Tech Support with corresponding logs.

Best regards,