View Full Version : FXO and 2X - losing config?

11-01-2010, 02:38 PM
Have a 2X and and FXO (with 3 analogue trunks), they have been working without any issues for ages. Suddenly last week one could make no out going calls, and not receiving incoming calls. However internal calls still routed as normal, including the AA etc.
Initially I thought that it might be a problem related to the telco, since the ADSL on the first analogue line has been down for about a week. However when I connected up an analogue phone directly to the trunks, I could dial out and receive calls.
So I had a look at the FXO, and decided to restore a previous working back up. After the back up loaded, the system behaved as normal again for the rest of the day.

The following day, the system would only receive calls, but no one could dial out. Unfortunately I was not able to attend to that on Friday, so today I restored the same back up to the FXO, the system behaved as normal again. Later in the afternoon, one could not dial out again periodically. I suspected a hardware failure on the FXO and got a replacement in, which I put down late this afternoon. The FXO is set up as a slave to the 2X, and it registers to the 2X

Since then though, the 2X displays the same error message when I go to the FXO Settings page: "Warning, FXO not installed". Incoming calls were routed to the AA, the correct message(s) play, but I can not dial an extension directly, I get the error message "Extension is currently unavailable" played back. The AA will also fails to route the calls if no extension is selected.

I've gone over the IG and AG for the FXO, but there is no reference to this. What I did notice though is that the new FXO is on software 5.1.13, where as the old one is on 5.0.11, and the 2X is also on 5.0.16. Without internet access on site, I was not able to download the corresponding software for the 2X.

I then proceeded to put the old gateway back - none of the settings were changed, but the 2X still displays the same "Warning, FXO not installed", and only inbound calls are currently routed. When trying to make an outbound call, the SNOM displays the message "Not registered 0nnnnnnnn" (n = number dialed) and the call is disconnected.
I restored the known back up to the FXO again, but to no avail. So now the site can only receive calls, who knows for how long?

This has me completely baffled. Right now I have a million questions, but to narrow it down a bit:

- What are the chances that the fault is on the 2X rather than the FXO?

- Is there any specific setting I should have a look at on either or both systems?

- Dose the fact that the new gateway is on 5.1.13 make a difference at all?

Thanks in advance for any assistance :)

11-02-2010, 12:19 PM
I got hold of a colleague from another co today, we had a good look at the 2X: it was missing a routing table / pattern causing the outbound calls to fail. I don't recall seeing a matching one there previously, which means it's a small mystery that the system worked up until now.
Since I didn't install it, I may have made some assumptions on the call routing patterns. Let's see how it goes.