PDA

View Full Version : CLI on forwarding with QuadroISDN



lunacom
04-27-2009, 10:18 AM
Hi,

i've surfed the forum with no luck... if there's a thread that explain a solution, please give me the link.
What is the correct way to route incoming call from Voip to ISDN with a quadroISDN?
I've configured this way: added an extension, registered ext. with Voip provider, then forwarded ext. to a specific pattern and made a specific call route.
It works but on ISDN phone i see ext. number (999) not calling number. On call stats i see: "John Doe" <1234@123.123.123.123> | 999 | call forwarded.
Please give me some hints...

Regards, Lunacom.

KSComs
04-27-2009, 06:26 PM
Is your question based upon statistics ? if so this is a filtering injection thing that is achieveable.. CLI injection is another thing ...

lunacom
04-28-2009, 02:09 AM
No, don't care about stats...
My question is: how can i have calling number, not ext. number, on ISDN phone display? (i.e. correct way to handle incoming Voip calls with QuadroISDN attached to a ISDN PBX).
I don't understand if problem is concerning how quadroISDN manage calls from Voip to ISDN...

KSComs
04-28-2009, 09:23 AM
I am not going to guess with your deployment .. can you be more specific with your setup ie all hardware...

What is the ISDN phone ? Where is that connected to ?

lunacom
04-28-2009, 10:08 AM
Well, I try to be more specific... please be patient. My English isn't very good.

My question would be generic, because we have many requests from customer on enabling Voip service via QuadroISDN with variuos ISDN PBX.
I have a quadroISDN and a ISDN PBX (i have tried also with a ISDN phone) with 1 free BRI. So i have configured 1 QuadroISDN port in network mode and connected with ISDN PBX.
At the same time i have configured a Voip carrier on QuadroISDN (add ext., config. sip service on ext. and enabled unconditional call forwarding).
When i call the Voip number yet configured (from a PSTN or mobile line), i have incoming call on ISDN pbx/phone but i don't see PSTN or mobile caller number, i see extension number...
So, i was wondering how to configure Quadro for correct handling of caller number.

Regards.

davrays
04-28-2009, 02:17 PM
As far as I know, with the way you configured you should get caller ID displayed correctly... so probably we will need to look at the logs to find out the reason (maybe there is some checkbox you set incorrectly..)

You can try another (potentially better and more flexible) way meanwhile - leave the extension you created as it is (so calls reach the Quadro), but set ON the "Route all SIP calls to Routing" checkbox on the "Call Routing" page. Then create a route rule matching the destination number coming from SIP, and route it to ISDN. For example, if SIP calls you get are directed to 12345, create a rule in the CRT with
pattern=12345, NDS=0, call type=ISDN,...,no filter yet.

See if you have this working and what you see as a caller id in this case... If this works you will need to set the correct inbound filter on that rule, so aliens cannot use that..

Best regards,
David

lunacom
04-29-2009, 11:00 AM
Thank you Dav!

way you suggested is good; now i have correct caller ID.
Now i will look at logs to understand why it goes wrong when applying forwarding.

Thanks!