PDA

View Full Version : Error outgoing voip carrier........Trying to connect , please wait



hsi.net.au
12-15-2008, 09:17 PM
Howdy

I have this QuadroFXO Gateway. It's wan port is in a Dlink ADSL router/modem. The modem does all internet login/authenitcation. The QuadroFXO gets a DHCP address from the router [it only has 1 address to choose from for testing putposes]. All good. Then I make an external call to Gotalk carrier. I get the "Waiting to connect , please wait." message over and over. But ocassionally , wow , it works. Sometimes even first time. The logs say i have this problem.

15:21:23 NetAgent::SendMessage # There isn't matching socket to send

what the ? Sounds like NAT problem , but where do i start looking?

All incomming test calls on Voip Carrier number is OK.

The ADSL router has all ports forwarded to the ip adresss of the QuadroFXO Gateway.

More detailed logs below.

Also somtimes i get 401 unable to atheticate [but only sometimes].

Any suggestions , this is driving me nuts.

Cheers
Cameron






.................................................. ........
15:21:23 Try to send SIP message # (12/12/2008 05:21:23:134 GMT) # TCP # 949 bytes # buff size 0 # from: 192.168.0.3:5060 # to: 202.169.178.10:5060

***************************** SIP message buffer start *****************************
INVITE sip:0447050020@sip.gotalk.com SIP/2.0
Via: SIP/2.0/TCP 255.255.255.255:5060;branch=z9hG4bKEPSVBUS72cfffa1-8c63-4e91-a033-23eab5e678cc
To: <sip:0447050020@sip.gotalk.com>
From: "Kim 12" <sip:09448957@sip.gotalk.com>;tag=1229052682b71a0a5a-6ff0-4838-8e53-a84849653ac1
CSeq: 228 INVITE
Call-ID: 18564897353159206_f8a936d3-4e4c-4ec9-96ee-9b25c681a607@quadroFXO.HSI.NET.AU
Allow: INVITE, ACK, CANCEL, BYE, OPTIONS, INFO, SUBSCRIBE, NOTIFY, REFER, MESSAGE, UPDATE
Contact: "Kim 12" <sip:09448957@255.255.255.255:5060;transport=TCP>
Content-Type: application/sdp
Supported: replaces, norefersub
User-Agent: Epygi Quadro SIP User Agent/v5.0.10 (QUADRO-FXO-IPPBX)
Max-Forwards: 70
Content-Length: 235

v=0
o=09448957 28 833 IN IP4 255.255.255.255
s=-
c=IN IP4 124.214.11.65
t=0 0
m=audio 6084 RTP/AVP 0 8 18 101
a=rtpmap:0 pcmu/8000
a=rtpmap:8 pcma/8000
a=rtpmap:18 g729/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
***************************** SIP message buffer end ******************************

15:21:23 NetAgent::SendMessage # There isn't matching socket to send

hsi.net.au
12-15-2008, 09:43 PM
Some more info before anyone asks.


Sip Registration Section
.................................................. ...................
Registration on SIP Servers
Extension Reg. Name Server Registered Registration Time
98 09448957 sip.gotalk.com Yes 16-Dec-2008 13:22:41


Detected connection type: Full Cone NAT (external IP: 123.211.11.65:5060).
.................................................. .....................

under 'line status' it says this
.................................................. ....................
Extension: 98
Display Name: Gotalk (added by VoIP Carrier Wizard)
Phone state: Temporary offline
Number of active calls: 0
.................................................. ......................

'network status' shows this
.................................................. ......................
Interface name IP address Subnet Mask Properties Monitor
LAN 172.30.0.1 255.255.0.0 MAC: 00-09-BD-01-3B-76 Watch LAN
WAN 192.168.0.3 255.255.255.0 MAC: 00-09-BD-01-3B-77 Watch WAN

Default Gateway: 192.168.0.1
DNS Server: 192.168.0.1

Services
Service Name Status
NTP Server Running
NTP Client Running
DHCP Server Running
DHCP Client Running
DNS Running
Firewall Low
NAT Running
PPP Stopped
.................................................. ...............


in my 'events' i have these
.................................................. .................
New Fri Dec 12 13:32:37 2008
1 STUN port detection Successful port(s): 5060, 6000, 6002, 6004, 6006, 6008, 6010, 6012, 6014, 6016, 6018, 6020, 6022, 6024, 6026, 6028, 6030, 6032, 6034, 6036, 6038, 6040, 6042, 6044, 6046, 6048, 6050, 6052, 6054, 6056, 6058, 6060, 6062, 6064, 6066, 6068, 6070, 6072, 6074, 6076, 6078, 6080, 6082, 6084, 6086, 6088, 6090, 6092, 6094, 6096, 6098; View STUN settings


NAT traversial settings
.................................................. ....................
Primary STUN server: stun.epygi.com
Primary STUN Port: 3478
Secondary STUN server:
Secondary STUN Port:
Polling interval: 1 day
Keep-alive interval: 120 second(s)
NAT IP checking interval: 300 second(s)

Nat raversal for sip = Automatic




wait up..... am i suposed to have something under "sip Parmeters"

UDP = use stun
tcp = nothing

KSComs
12-16-2008, 02:32 AM
Cameron alter your network as via the following snapshot..

Ie
Modem - wan 123.211.11.65
Modem - lan 192.168.2.1 ( ignore if combo device )

Router - wan 192.168.2.2 ( ignore if combo device )
Router - lan 192.168.0.1

Epygi - wan 192.168.0.3 <------ set it as static, gateway of 192.168.0.1 with dns from 192.168.0.1
Epygi - lan 172.30.0.1

Now seeing as it is for testing purposes.... DMZ the Epygi in the router - ie DMZ 192.168.0.3. This will ensure that all packets are sent and received to the Epygi without a hitch.

I know that your stats seem like everything is ok in the Epygi... but it smells like an rtp stream packet problem...

DMZ the Epygi and retest .. if it works then .. look up my post on "Ports to Open" it might be you have missed one.

Regards

Kevin

davrays
12-19-2008, 11:59 AM
Cameron, as you can see in your log:

15:21:23 Try to send SIP message # (12/12/2008 05:21:23:134 GMT) # TCP # 949 bytes # buff size 0 # from: 192.168.0.3:5060 # to: 202.169.178.10:5060 ,

your SIP connection is done using TCP (instead of the more common UDP). Did you configure that intentionally?

KSComs
12-20-2008, 04:39 PM
Contact: "Kim 12" <sip:09448957@255.255.255.255:5060;transport=TCP >

Extension 12 = tcp to the voip itsp account.. did you set your voip extension as tcp instead of udp > that might be it perhaps?


Regards

Kevin

hsi.net.au
01-22-2009, 11:29 PM
Thanks for the heads up on the Voip trunk setting as TCP instead of UDP. Works now 95% of the time.
Re ...ext 12 = TCP rather than UDP ?
No I didnt set it to that [well i dont remember] How do I change that back to UDP

Cheers
Cameron

davrays
02-05-2009, 11:48 AM
I am not sure where did you configure that :)
Typically you select the transport protocol (UDP/TCP) for outgoing calls in the Call Routing table. You should look there first.. :)

Best regards,
David