PDA

View Full Version : No leading zero bug in sip user name



hsi.net.au
09-09-2008, 07:05 AM
Hi all

I have an issue with a sip account name.
The name/account is just numbers with a leading Zero [09448957]
On registration attemps the leading Zero disappears as per the logs below [9448957].
Any tricks or workarounds?

Maybe someone else could try a new sip trunk with a leading 0 and see if the fault is not just in my system?

That would be a big help.

Takes like 3 minutes , youll need to look in the logs and see what the registration attempt looks like.

Same bug in ver 4XX release before upgrading to the latest 5XX , same fault :O/

Any other Gotalk users using all numbers with leading zeros as their username/account?

Any help appreciated.


Cameron

............................
.

OPTIONS sip:9448957@sip.gotalk.com:5060 SIP/2.0
Via: SIP/2.0/UDP
58.105.111.240:5060;rport;branch=z9hG4bKEPSVBUSe67 9d7cf-be24-49ef-87c4-f82a85dccb2d
To: "Gotalk (added by VoIP Carrier Wizard)" <sip:9448957@sip.gotalk.com>
From: "Gotalk (added by VoIP Carrier Wizard)"
<sip:9448957@58.105.111.240>;tag=121848596771a1a217-fb66-4762-bb7d-7d6a60d5857d
CSeq: 26 OPTIONS
Call-ID: 98286c1d-f30a-4689-9191-5f98dc40b73f@quadroFXO.HSI.NET.AU
Contact: "Gotalk (added by VoIP Carrier Wizard)" <sip:9448957@58.105.111.240:5060>
User-Agent: Epygi Quadro SIP User Agent/v5.0.10 (QUADRO-FXO-IPPBX)
Max-Forwards: 70
Content-Length: 0

***************************** SIP message buffer end ******************************

06:26:03 Receive SIP message # (11/08/2008 20:26:03:570 GMT) # UDP # 469 bytes # buff
size 1 # from: 202.169.178.10:5060 # to: 192.168.1.100:5060

***************************** SIP message buffer start *****************************
SIP/2.0 400 Bad Request
Via: SIP/2.0/UDP
58.105.111.240:5060;rport;branch=z9hG4bKEPSVBUSe67 9d7cf-be24-49ef-87c4-f82a85dccb2d
To: "Gotalk (added by VoIP Carrier Wizard)" <sip:9448957@sip.gotalk.com>;tag=10331d4d
From: "Gotalk (added by VoIP Carrier Wizard)"
<sip:9448957@58.105.111.240>;tag=121848596771a1a217-fb66-4762-bb7d-7d6a60d5857d
Call-ID: 98286c1d-f30a-4689-9191-5f98dc40b73f@58.105.111.240
CSeq: 26 OPTIONS
User-Agent: ENS2.5.31-IS1
Content-Length: 0

davrays
09-10-2008, 09:14 AM
Just tried the same in my Quadro4x with 5.0.11 installed. Everything works correctly: device is sending the registration with the leading zero.
So either this is a Q6L-specific bug, or something is wrong with the configuration. Can you look at your Extension Table and confirm you have extension with username "09448957", and when you uncke/check the "SIP registration" checkbox on that extension, Quadro sends REGISTER message for "9448957" (without leading zero)?

Best regards,
David

hsi.net.au
12-11-2008, 05:21 PM
Thanks

The voip carrier wizard seems to have dropped the leading zero in the "extension management" area , added the zero and sip registers ok.
Cameron

davrays
12-12-2008, 10:12 AM
Thanks

The voip carrier wizard seems to have dropped the leading zero in the "extension management" area , added the zero and sip registers ok.
Cameron

Well.. somebody has definitely dropped that leading zero.. :) but I doubt the "VoIP carrier Wizard" is te guilty.. :) I tested that with usernames containing leading zero, but it work flawlessly - all leading zeros are preserved. So maybe somebody just forgot to enter that leading zero..? ;)

Best regards,
David

hsi.net.au
12-15-2008, 08:43 PM
Yep ... If you tested it OK , then most likely keyboard error.

Thanks for checking that out.