PDA

View Full Version : Remote Extensions broken in 5.0.11?



skyplonk
08-10-2008, 07:27 PM
Hi All,

Has anyone else had a issue like this with Remote Extensions?

We have a site that has been running remote extensions for 1 year plus with no issues, 2 weeks ago we did the firmware update to 5.0.11 and now the remote extensions only get one way audio when calling local extensions or other remote extensions.

The remote phones are Snom 360s, running over an ADSL connection, full speed both ways, static IP, and STUN to break out of NAT. These have been connecting directly to the WAN port of the Quadro 16x, as the Quadro is running a PPPoE connection and static IP.

Remote extensions are setup in the Quadro with Symmetrical RTP and RTP proxy enabled.

These worked fine for almost a year with no issues at all. Since the upgrade we only get one way audio. To test I setup another Quadro 16x we have in stock running 4.1.58 firmware and setup the system as above, and the remote extensions worked fine. Go back to our main box running 5.0.11 and we get one way audio again.

So, I spent all weekend working on it no luck….. Now this is strange if I call a DDI (attached to the remote extension) from any extension it works and I can hear him, and we have 2 way audio, if I call his extension number directly from remote ext there is no audio..


Works calling DDI for example:

ext 260 calling 090 555-1280 (DDI of ext 280)
Remote EXT --> Quadro WAN --> Out WAN to ITSP --> ISTP --> IN Quadro WAN from ITSP --> OUT LAN to Local Phone


Does not work calling ext direct:
ext 260 calling ext 280
Remote EXT --> Quadro WAN --> Out Quadro LAN to LocalPhone

Remote extensions can call any external number, PSTN or IP and have no issues with one way audio, and calls attached to the remote extensions DDI also work fine.

Any ideas anyone?

Cheers

KSComs
08-10-2008, 11:23 PM
I have a similar problem which has forced me to go back to 4.1.57 to try and resolve the issue as well as diagnose it further. Down grading was a pain and it seemed that the ethernet port changed to crossover connection only which seemed very strange.

Anyway after upgrading from 4.1.57 to 5.0.11 - Remote extension in the US ( Brother ) to Australia where the Epygi Quadro is, he was getting no audio and yet I heard him without a problem.

Ill investigate further once I have confirmation back from brother that it is working again after the down grade.

Regards

Kevin

teamnet
08-11-2008, 03:18 AM
Using Zoiper free -> Q4xi 5.0.11 over a VPN (no STUN or NAT) and no issues whatsoever.

KSComs
08-11-2008, 05:41 AM
Using Zoiper free -> Q4xi 5.0.11 over a VPN (no STUN or NAT) and no issues whatsoever.


VPN via the wan port, or via the lan port of the Epygi ?

davrays
08-11-2008, 12:24 PM
Hi guys

This looks like the Symmetric NAT issue, however I tested the Symmetric RTP functionality in 5.0.11, and it seems to be working correctly.
Which direction do you have no voice - TO rem.ext., or FROM? can you make a network capture (netcapture.cgi) containing such call and attach here (if there is no secret info) or send to Epygi TSS?

Best regards,
David

skyplonk
08-11-2008, 05:31 PM
Hi Guys,

Remote ext calling local internal ext - Remote hears nothing, local hears fine
Local internal ext calling remote ext - Remote hears nothing, local hears fine
Remote ext calling external over PSTN/ISDN line - Fine both ways
Remote ext calling external over ITSP - Fine both ways
External caller calling remote ext DDI - Fine both ways

Does that make sense?

Cheers

sjet701
08-12-2008, 02:51 AM
Maybe worth cut / pasting the successful call statistics for the tests you have listed. One avenue is to tighten up on your codecs, I seen many examples of one way audio the fact that you can hear perfect with a SIP/PSTN and not a SIP/SIP backs this theory up / Lee, SMT

skyplonk
08-12-2008, 08:47 PM
@sjet701 CODEC changes make no differance. Tried all that.

Remember that the system worked fine before the update, nothing else has changed now they do not work. And also SIP to SIP calls to or from the remote ext. work fine if calling externally via an ITSP or Epygis SIP service.

davrays
08-13-2008, 08:35 AM
Hi skyplonk,

thank you for detailed description. It was really useful. When testing Symmetric RTP functionality before I called to the autoattendant (00), which is the same as calling to PSTN/ISDN line, as in both cases RTP streams are termonated on Quadro. In such cases Symmetric RTP works, as I told above. So if you call from rem.ext. to AA, or PSTN or FXS extension, the stream will be bidirectional.

But when calling to te extenion attached to an IP Line (which I tested after I got the problem describtion from you), this Symmetric RTP indeed doesn't work in 5.0.11. We are working now to find the reason.

Thanks (and some more info is coming soon),
David

P.S. We got also a request from TSS lately. Seems the forum feedback was faster anyway this time :)

skyplonk
08-14-2008, 05:06 PM
Great, thanks for all your help!!

Cheers

teamnet
08-15-2008, 12:51 AM
Yeah, I am getting this on 5.0.11 between IP lines over a SIP Tunnel now as well! In addition to the 30 second limit on calls before dropping - though this is most likely the firewall we are using I believe.....

davrays
08-15-2008, 09:26 AM
As soon as your calls anyway are dropping after 30 seconds, the one-way RTP is not a big problem for you, I guess :D

The fix for the one-way RTP on remote extensions is ready, but I need to test the case with SIP Tunnel too before publishing the version with a fix.

If somebody needs a fix very urgently, he can contact Epygi TSS to get a temporary image with rem.ext fix only.

Best regards,
David

teamnet
08-15-2008, 10:54 PM
Will wait for your testing David.

Any way we can be notified of particular software releases other than by searching forums or downloads? I visit the forums regularly but didn't even notice for over a week that 5.x was available!

Drilling down into the downloads area for each specific device or category is quite time consuming and it would be great to have some kind of subscription to a list/page/email/?? showing the most recently updated software for all/particular platforms and a link to the download.

DigiVoice
08-17-2008, 11:25 PM
Hi David,

Can I please get update as I have a urgent need to get the remote ext. working again?

Cheers

davrays
08-19-2008, 08:36 AM
Hi guys,

@teamnet: there is such mecanism to receive notification emails, though they come with some delay. But seems there is no way to automatically subscribe to that mailing list yet. You need to contact Epygi to subscribe...
I will ask our Product Manager (Warren), to comment on this.

@DigiVoice: the release is ready and tested; we gave that to several customers. It'll be published as soon as we get confirmation from customers that the problem is solved. If you need that urgently, open a ticket, and you will receive the release promptly.

Best regards,
David

davrays
08-29-2008, 08:56 AM
Update: the firmware containing the Remote Extension fix, is released: that is 5.0.12.
The corresponding notification is sent through the subsription list, but as many people are out of that list, I am informing you here, in the forum:
new publised files are:
QuadroM32x 5.0.10
Quadro4x/16x 5.0.12
Quadro2x 5.0.12
Quadro6L 5.0.22
Quadro Patch file for SugarCRM
QCC 1.0.9

The fix is included in all corresponding releases (to the first four, of course :) )
Regarding the subscription: Warren is on vacation, so probably he will answer after his return.

teamnet
08-30-2008, 06:33 AM
Thanks for the update...