Results 1 to 9 of 9

Thread: Forwarding a phone call through a sip account to an external line: no sound

  1. #1

    Default Forwarding a phone call through a sip account to an external line: no sound

    Epygi Quadro 2xi
    Latest firmware installed

    Sip trunk (sipgate) on extension 99. Set to UCF (unconditional call forwarding) to extension 92 and 52

    Extension 52 set to UCF to an external mobile number: 8 <mobile number> where 8 is the prefix configured for the forwarding sip account.

    When there is an incoming phone call on sipgate (ext 99), the call is correctly forwarded to 52, then extension 52 dials the mobile number, the mobile phone rings, but when picked up neither party can hear the other party. No sound at all.

    I tried forwarding through other sip accounts (5 are configured on the Epygi), but they all have the same problem: no sound

    When forwarding through ISDN: UCF is set to 5 <mobile number> where 5 is the prefix for the ISDN lines, then it works properly. No sound issues.

    When dialing directly (internally) to extension 52 from a phone, then the mobile phone is connected properly as well, with proper sound!

    Thank you very much in advance for any help!!!

  2. #2

    Default

    Set 52 to be forwarded to the call routing tables and allow anything to dial 52 in the CRT to the mobile number. Unless you have RTP that is not lining up then the call should go through with audio.




    Quote Originally Posted by keeskoets View Post
    Epygi Quadro 2xi
    Latest firmware installed

    Sip trunk (sipgate) on extension 99. Set to UCF (unconditional call forwarding) to extension 92 and 52

    Extension 52 set to UCF to an external mobile number: 8 <mobile number> where 8 is the prefix configured for the forwarding sip account.

    When there is an incoming phone call on sipgate (ext 99), the call is correctly forwarded to 52, then extension 52 dials the mobile number, the mobile phone rings, but when picked up neither party can hear the other party. No sound at all.

    I tried forwarding through other sip accounts (5 are configured on the Epygi), but they all have the same problem: no sound

    When forwarding through ISDN: UCF is set to 5 <mobile number> where 5 is the prefix for the ISDN lines, then it works properly. No sound issues.

    When dialing directly (internally) to extension 52 from a phone, then the mobile phone is connected properly as well, with proper sound!

    Thank you very much in advance for any help!!!

  3. #3

    Default

    Thank you very much for your reply.
    You basically made 2 suggestions:
    (1) Set 52 to be forwarded to the call routing tables
    (2) allow anything to dial 52 in the CRT to the mobile number.
    Regarding (1) where do I do that? I thought that extensions are routed through the CRT automatically anyway.
    Regarding (2)
    I tried to set up the following rule in the routing table, The mobile number is 13 digits long:

    -----------------------
    Destination Number Pattern: ?????????????
    Number of Discarded Symbols:
    Prefix:
    Suffix:
    Destination Type: IP-PSTN
    Metric: 10
    Description: forwarding ext 55
    Routing Call Settings
    Use Extension Settings: 55
    Keep Original Caller ID: No
    Add Remote Party ID: No
    Destination Host: sipgate.de
    Destination Port: 5061
    Username: 2xxxxxxe2
    Transport Protocol for SIP: UDP
    Restrict the Number of Simultaneous Calls: No
    Use RTP Proxy: No
    Activity Timeout: Disabled
    Call Duration Limit: Disabled
    AAA Required: AAA disabled.
    Failover Reason(s): None

    Routing Call Source Information
    Discard Non-Numeric Symbols: No
    Source Number Pattern: 55
    Source Type: PBX
    Caller ID Modification
    Number of Discarded Symbols:
    ---------------------------------

    Somehow, this rule is not picked up when forwarding a call from extension 55. I even put the rule first, but that didn’t help.
    What are the proper settings to implement suggestion (2)?

    As an alternative, I also tried to put the mobile number as a SIP call directly in the UCF table as follows:
    SIP-1234567890123@sipgate.de:5060
    But then I get the voice message from the Epygi: “Access to this phone number blocked”

    I am at a loss here. How can I implement (1) and (2) as you suggested?

  4. #4

    Default

    Hi Ed

    Just 1 x suggestion is needed to be enacted upon first.

    In the extension routing table, create an extension 52... forward that immediately to the call routing table as (Auto) that will send the call through to the CRT from the ERT, in the CRT have an entry 52 , delete 2 digits and replace with the mobile number but dont have any restrictions on dialling 52.

    This works as stated and will allow audio to go through unless you have an issue with the RTP settings.

    Kev

    Quote Originally Posted by keeskoets View Post
    Thank you very much for your reply.
    You basically made 2 suggestions:
    (1) Set 52 to be forwarded to the call routing tables
    (2) allow anything to dial 52 in the CRT to the mobile number.
    Regarding (1) where do I do that? I thought that extensions are routed through the CRT automatically anyway.
    Regarding (2)
    I tried to set up the following rule in the routing table, The mobile number is 13 digits long:

    -----------------------
    Destination Number Pattern: ?????????????
    Number of Discarded Symbols:
    Prefix:
    Suffix:
    Destination Type: IP-PSTN
    Metric: 10
    Description: forwarding ext 55
    Routing Call Settings
    Use Extension Settings: 55
    Keep Original Caller ID: No
    Add Remote Party ID: No
    Destination Host: sipgate.de
    Destination Port: 5061
    Username: 2xxxxxxe2
    Transport Protocol for SIP: UDP
    Restrict the Number of Simultaneous Calls: No
    Use RTP Proxy: No
    Activity Timeout: Disabled
    Call Duration Limit: Disabled
    AAA Required: AAA disabled.
    Failover Reason(s): None

    Routing Call Source Information
    Discard Non-Numeric Symbols: No
    Source Number Pattern: 55
    Source Type: PBX
    Caller ID Modification
    Number of Discarded Symbols:
    ---------------------------------

    Somehow, this rule is not picked up when forwarding a call from extension 55. I even put the rule first, but that didn’t help.
    What are the proper settings to implement suggestion (2)?

    As an alternative, I also tried to put the mobile number as a SIP call directly in the UCF table as follows:
    SIP-1234567890123@sipgate.de:5060
    But then I get the voice message from the Epygi: “Access to this phone number blocked”

    I am at a loss here. How can I implement (1) and (2) as you suggested?

  5. #5

    Default

    Thanks a lot, Kevin!!

    I did the following:
    (1)
    Users/extension management I created a new extension 52
    (2)
    Users/extension management/call queue settings
    Enable: ticked
    Call Queue Size: 4
    Max Calls Presented to Extension: 1
    Enable Redirection on Timeout: ticked
    Call Queue Message Repetition Count: 5
    Call Type: Auto
    Address: CRT
    ZeroOut Redirection:
    Voice Mail selected
    (3)
    Under telephony/call routing/CRT I created the following rule:
    Routing Call Type
    Destination Number Pattern: 52
    Number of Discarded Symbols: 2
    Prefix:
    Suffix: 30041xxxxx2084 (xxxxx added for privacy reasons)
    Destination Type: PBX
    Metric: 10
    Description: 52
    Routing Call Settings
    AAA Required: AAA disabled.
    Failover Reason(s): None
    Routing Call Source Information
    Discard Non-Numeric Symbols: No
    Source Number Pattern: *
    Source Type: PBX
    Caller ID Modification
    Number of Discarded Symbols:
    Prefix:


    Results:
    When dialing extension 52, the PBX answers with the following message:
    “Number dialed does not exist”

    Where did I go wrong?

  6. #6

    Default

    Call Queue Size: 4
    Max Calls Presented to Extension: 1 <------ 4
    Enable Redirection on Timeout: ticked
    Call Queue Message Repetition Count: 5
    Call Type: Auto
    Address: CRT <----- 52

    Source Number Pattern: * <----
    Source Type: PBX <------

    No Pattern matching needed

  7. #7

    Default

    I made the first 2 changes (arrow 1 & 2) as you indicated.

    Regarding "Source Number Pattern", I tried to leave it empty, but then the following message came:
    Error: Incorrect Source Number Pattern - field should not be empty
    So I left the * & PBX

    After these changes, the results same as before:
    When dialing extension 52, the PBX answers with the following message:
    “Number dialed does not exist”

  8. #8

    Default

    Dont use pattern matching.



    Quote Originally Posted by keeskoets View Post
    I made the first 2 changes (arrow 1 & 2) as you indicated.

    Regarding "Source Number Pattern", I tried to leave it empty, but then the following message came:
    Error: Incorrect Source Number Pattern - field should not be empty
    So I left the * & PBX

    After these changes, the results same as before:
    When dialing extension 52, the PBX answers with the following message:
    “Number dialed does not exist”

  9. #9

    Default

    We are making progress

    I unticked Filter on Source / Modify Caller ID and that disabled the option all together

    I found one more mistake in the CRT rule:
    Destination Type: PBX, this should be:
    Destination Host: sipgate.de
    Destination Port: 5061

    Now, when I dial 52 through a phone in the office, I am actually forwarded to the mobile number !

    So this is set up properly. 2 issues remain:
    (1) When a call comes into 52 through another extension, extension 52 goes on voice mail immediately and I have no idea where to switch that off. I searched though the whole manual and forum. I am clueless.
    (2) When I dial 52 though a phone, every second call is timed out. Message as follows: “trying to connect, please wait (3x). Number dialed temporarily unavailable.” This never happens when I dial through this SIP trunk from a regular phone. Somehow, the call takes too long to set up.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Unconditionnal Call forwarding failure from external call
    By Synertic in forum Troubleshooting and Problems
    Replies: 1
    Last Post: 09-20-2012, 12:49 PM
  2. Check your external phone line.
    By marisunc in forum Troubleshooting and Problems
    Replies: 2
    Last Post: 12-01-2011, 04:12 PM
  3. Replies: 3
    Last Post: 08-05-2009, 08:45 AM
  4. Call Routing table and external forwarding
    By mountrcg in forum 'How Do I' Questions
    Replies: 2
    Last Post: 04-14-2008, 01:34 AM
  5. Call Forwarding to external number
    By t_h_048d3 in forum Suggestions and Feedback
    Replies: 3
    Last Post: 09-13-2007, 03:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •