Results 1 to 3 of 3

Thread: Configure SIP Ports for 2+ Remote IP Phones

  1. #1

    Question Configure SIP Ports for 2+ Remote IP Phones

    Hello,

    I have a scenario here which has a single flaw that I am sure is tied to IP address & port binding.

    The connected equipment is as follows:

    Quadro <-> Internet <-> NAT Router <-> Remote IP Phone #1 & #2.

    When only one IP phone connected and registered, full communication both ways with crystal clear service to and from the Quadro.

    When two IP phones are connected and registered, only the first has communication both ways. The second has no audio at all. However, the two remote IP phones can call each other and have perfect communication with each other, as well as see accurate BLF of each other as well as the local extensions. Of course, if both are rebooted at the same time, no telling which will get bound properly. If the two are booted opposite (working unplugged & non-working rebooted) the previously non-working begins working, and the original working becomes non-working. This is definitely a source vs. destination port mapping issue. Especially knowing that the two remote IP phones can communicate with each other perfectly because no NAT is taking place locally between them.

    I know the problem going out is that the NAT device is mapping the source port 5060 to some random number for both remote extensions but the Quadro is only sending back on 5060, regardless. I thought I could change the SIP port on the extension management page of Quadro to 5061 for remote #2, but that does not seem to make a difference. I know I would also have to change the port on remote IP phone #2 as well.

    I am asking for assistance in how to be sure I have the Quadro programmed to communicate with specific extensions on specific ports only. The extension management page does have a SIP port entry field, but these extensions do not register on a sip server so that checkbox Registration on SIP Server is not checked.

    Anybody have a sample they can provide me?

  2. #2

    Default

    Just recently came into this issue again while attempting to program two remote IP phones to a QX50. The Epygi PBX is directly connected to the Internet at location A. Two remote phones are located behind a single NAT router in location B. One phone registers and works without issue. Second phone sends register request to PBX, and PBX attempts to respond, but return PBX traffic destined for second phone never reaches second phone.

    I always knew that for two VoIP devices to send/receive individualized traffic reliably, the ports must be changed for one of them. For whatever reason I believed this port change was on the PBX itself. I tried everything I could think of to locate where I would tell the PBX to use port #nnnn for the second phone. I even tried specifying the custom port number in the second phone's SIP server like n.n.n.n:5062. Still did not work. That was why this forum post was originally created back in 2014.

    Although this is a really old post, it appears as though it has been viewed almost 2,000 times with no replies. I wanted to post the solution here so that any others with this dilemma do not have to struggle:

    For two or more remote phones connected to the same NAT router needing to register to a single PBX, all one must do is change the port used in each IP phone's network config settings. No port changes are required at all on the PBX as the PBX will ALWAYS listen in on ports 5060 and 5061 (unless changed on the PBX under Telephony -> SIP). Next, when configuring the extension registration settings of the remote phones, be sure to use the PBX server IP and PBX port number as normal. But on each IP phone, change the SIP port to a unique set of ports (ie: 5062). This will cause the IP phone to contact the PBX on default port 5060, but request the PBX to send traffic BACK to the IP phone using port 5062.

    Linear Example:
    Phone 1) Connects to PBX public IP n.n.n.n:5060, PBX talks back to phone public IP n.n.n.n:5060 (SIP port default on phone)
    Phone 2) Connects to PBX public IP n.n.n.n:5060, PBX talks back to phone public IP n.n.n.n:5062 (SIP port changed on phone to use 5062 using Network -> Advanced - SIP)
    Phone 3) Connects to PBX public IP n.n.n.n:5060, PBX talks back to phone public IP n.n.n.n:5064 (SIP port changed on phone to use 5064 using Network -> Advanced - SIP)

    This may seem very basic to most--including myself--but I still struggled with it. I am hoping this helps someone else.

  3. #3

    Default

    Some handsets overcome this by automatically changing the UDP SIP port it listens and transmits on, other handsets you have to change the port manually, in all instances your local router needs to be modified to assist with the sip to sip translation and again at the other ends router where the system is ie:

    Handset a - UDP 5060 SIP -- Router 5060 location a IP Address to SIP Server Router IP address - UDP 5060 - SIP Server IP address
    Handset b - UDP 5061 SIP -- Router 5061 location a IP Address to SIP Server Router IP address - UDP 5061 - SIP Server IP address
    Handset c - UDP 5062 SIP -- Router 5062 location a IP Address to SIP Server Router IP address - UDP 5062 - SIP Server IP address

    The above is easily solved by Routers that are intelligent and can do point to point natting - not usually found on residential style modems.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Configure IP phones from WAN
    By mbagshaw in forum 'How Do I' Questions
    Replies: 1
    Last Post: 03-12-2013, 01:55 AM
  2. Configure Quadro M8L and Phones to have Phones on WAN
    By flyboy_dea in forum 'How Do I' Questions
    Replies: 4
    Last Post: 06-08-2011, 09:57 AM
  3. Routing incoming SIP call - Dual E1 ports gateway
    By waik in forum 'How Do I' Questions
    Replies: 2
    Last Post: 07-07-2009, 06:56 PM
  4. Forward Incoming SIP calls to ISDN ports
    By cietech in forum 'How Do I' Questions
    Replies: 2
    Last Post: 06-11-2009, 07:02 AM
  5. How to configure Grandstream BT200 as Remote Extension
    By yobtrams in forum 'How Do I' Questions
    Replies: 4
    Last Post: 05-11-2009, 11:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •