Results 1 to 8 of 8

Thread: Clickatell SMS not working

  1. #1

    Default Clickatell SMS not working

    Hi - SMS setup is no longer working. Don't know what has changed but this is the message from the test:

    Sending sms...
    -> from: XXXXXXXXXX, to: XXXXXXXXXX
    -> message: "This is an automatically generated message. Please do not respond"
    -> username: XXXXX, password: ***********
    -> host: api.clickatell.com, port: 443, secure: yes, method: POST
    -> resource: "/http/sendmsg"
    -> parameters: "api_id=%apiid%&user=%username%&password=%password %&to=%to%&from=%from%&text=%text%"

    Resolved ip address 196.216.236.7 for api.clickatell.com.
    Creating TCP connection...
    Creating SSL connection...
    Error creating SSL connection.

    From a browser on the LAN side of the Quadro I can manually send SMS successfully using the HTTP Post command.

    Any suggestions?

    Thanks for any help

  2. #2

    Default

    Hello,

    Since Clickatell has changed its security support to TLSv1 against Quadro's SSLv2 the secure connection can't be established for sending SMS. By default Quadro uses security transport for Clickatell api to prevent the account's credentials from being unprotected within the Internet where it may be captured and used by "others".
    When you use a browser from the Quadro's LAN side with HTTPS, the browser supposedly supports TLSv1 and thats why it goes successfully and moreover unprotected HTTP requests will pass without any problem but which is not recommended.
    Supporting of TLSv1 for Clickatell api will be added and included in the next releases of Quadro.

    Thanks,
    Aram.

  3. #3

    Default

    Thanks for the update. I didn't see any reference to this issue being resolved in the just released update 5.3.22. When do you think a fix is likely to be released?

  4. #4

    Default

    Hello,

    The thing is when the 5.3.22 release was going to be published Clickatell worked just fine. I guess they changed their security requirements when the 5.3.22 release had been already released. If you need this fix urgently please contact Epygi support in order to get a special release for fixing the issue otherwise you will have to wait indefinitely till a new regular release is ready.

    Thanks,
    Aram.

  5. #5

    Default

    I believe the Clickatell integration stopped working sometime around December. 5.3.22 has only just been released this month.

    How can I make certain that this broken feature is in the list of fixes to be made for the next release? Is it already logged or is there a process to log the problem?

    Thanks for your help.

  6. #6

    Default

    Hello Jab,
    It might that in the mentioned period it wasn't working as well. As I already said you can contact Epygi support to get a new firmware where the issue is already fixed.

    Thanks,
    Aram.

  7. #7

    Default

    Thank you so much for offering update about Clickatell. I am also thinking to enable SMS API and doing research for this.

  8. #8

    Default

    Hi Everyone,

    We just wanted to sign up and let everyone one know that the IP address listed above will stop working after 22nd April 2018. Rather avoid hard coding IP addresses or use the new ones listed here - https://www.clickatell.com/faqs/answ...-ip-addresses/

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Upgraded my 2x to 5.1.27 & Clickatell isn't working
    By andy@telecomhelp.co.uk in forum Troubleshooting and Problems
    Replies: 3
    Last Post: 10-23-2009, 12:35 PM
  2. SMS recipient Germany cuts leading 0
    By mountrcg in forum Troubleshooting and Problems
    Replies: 4
    Last Post: 03-26-2008, 01:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •